Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 13
Registered: ‎08-03-2009
My Device: Not Specified

"Analyzing Sources" takes forever with new eclipse-plugin

Hi all,

 

after a os-reinstall of my development machine, I'm currently trying to get my project to run again. I downloaded eclipse 3.5 and the new plugin (version 1.1.2.201..) and copied all the sources into the project - and now I'm waiting. Eclipse tells me it's virtually done with "Building workspace" (100%) and currently "Analyzing sources". Eclipse will stay in this state for up to three hours while keeping one of my CPU cores busy at 100%. This happens every single time when I build the project. What is actually happening during this "Analyzing sources" and how can I turn it off?

 

I tried to get my project running now on two different machines (XP Professional,  Vista Business), both showing the same behavior.

 

I'm grateful for any suggestion!

KoMaXX

Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: "Analyzing Sources" takes forever with new eclipse-plugin

I'm pretty sure that's an Eclipse thing but that is weird. Have you tried removing and reinstalling Eclipse? Or the plugin?

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Developer
Posts: 13
Registered: ‎08-03-2009
My Device: Not Specified

Re: "Analyzing Sources" takes forever with new eclipse-plugin

Yes, I even tried setting up a fresh system with virtually nothing but a clean eclipse 3.5.2 and the current plugin installed. Same behavior.

I noticed, however, that the time "Analyzing sources" takes, is a function of the number of classes involved and the complexity of the build path. At first the project consisted of quite a few 'linked' folders, each with a lot of inclusion/exclusion rules. Now, I have copied all sources and assets into the project's source folder. This has somewhat improved the situation - but only so far that one "analyzing sources" takes now roughly 40 minutes.

Still too long to be really productive...

 

Am I really the only one encountering this Smiley Surprised

... weird.

New Member
Posts: 1
Registered: ‎04-29-2010
My Device: null
My Carrier: 3

Re: "Analyzing Sources" takes forever with new eclipse-plugin

I have the same issue here. I'm using Win7 32bit, eclipse 3.5 and installed the new plugin and the 5.0 sdk via update site. Anyone fixed this issue already?
New Developer
Posts: 11
Registered: ‎12-30-2008
My Device: Not Specified

Re: "Analyzing Sources" takes forever with new eclipse-plugin

[ Edited ]

I can confirm this happens on Win XP and Windows 7 32 bit, I just downloaded a fresh eclipse and jde today.

 

Developer
Posts: 1,305
Registered: ‎01-21-2009
My Device: Not Specified

Re: "Analyzing Sources" takes forever with new eclipse-plugin

It may be that Eclipse needs more heap memory. See the RIM note Specify the heap memory for Eclipse.




Solved? click "Accept as solution". Helpful? give kudos by clicking on the star.
New Contributor
Posts: 5
Registered: ‎05-06-2010
My Device: N/A
My Carrier: N/A

Re: "Analyzing Sources" takes forever with new eclipse-plugin

Even with specifying a heap size of 1 Gig, I am still seeing this issue. I have 4 linked source folders, along with my original src folder, and building is simply taking far too much time. I have well over 200 source files in my project.

 

This needs to be fixed.

New Contributor
Posts: 7
Registered: ‎05-11-2010
My Device: 9550
My Carrier: -

Re: "Analyzing Sources" takes forever with new eclipse-plugin

Any new help on this? I also would so much like to get answers to these: "What is actually happening during this "Analyzing sources" and how can I turn it off?"

 

It takes at least 30 minutes to analyze sources which is not very efficient.

Highlighted
New Developer
Posts: 13
Registered: ‎09-07-2008
My Device: Not Specified

Re: "Analyzing Sources" takes forever with new eclipse-plugin

I had the same problem. The JDE would compile my project in 20 seconds, Eclipse took 30 minutes or more. I noticed that once it did compile, it had 200,000 warnings, of which it showed me 100, they were all  'Signing required'. I turned off the Signing warnings, restarted Eclipse and now it seems ok.

Ian

New Contributor
Posts: 7
Registered: ‎05-11-2010
My Device: 9550
My Carrier: -

Re: "Analyzing Sources" takes forever with new eclipse-plugin

Thank you very much! Checking all the options on suppress warnings worked. Now the building takes only some seconds.