Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Developer
Posts: 2
Registered: ‎12-22-2008
My Device: Not Specified

rapc reports "Fatal Internal error: NullPointerException" in "Populating"

Hi --


I'm getting the following output from rapc (using -verbose):

     [exec] Populating
[exec] java.lang.NullPointerException
[exec] at net.rim.tools.compiler.e.x.a9(Unknown Source)
[exec] at net.rim.tools.compiler.g.c.a(Unknown Source)
[exec] at net.rim.tools.compiler.g.q.do(Unknown Source)
[exec] at net.rim.tools.compiler.e.x.a(Unknown Source)
[exec] at net.rim.tools.compiler.e.ai.if(Unknown Source)
[exec] at net.rim.tools.compiler.g.f.a(Unknown Source)
[exec] at net.rim.tools.compiler.h.c.do(Unknown Source)
[exec] at net.rim.tools.compiler.h.g.case(Unknown Source)
[exec] at net.rim.tools.compiler.h.m.if(Unknown Source)
[exec] at net.rim.tools.compiler.Compiler.a(Unknown Source)
[exec] at net.rim.tools.compiler.Compiler.l(Unknown Source)
[exec] at net.rim.tools.compiler.Compiler.a(Unknown Source)
[exec] at net.rim.tools.compiler.Compiler.compile(Unknown Source)
[exec] at net.rim.tools.compiler.Compiler.main(Unknown Source)
[exec] Fatal Internal error: java.lang.NullPointerException


I know which set of code changes has caused this failure, but have no idea how to prevent this happening without backing out the changes.  A generic Midp 2 client built from the same code works fine in the Sun WTK 2.x emus.


I've tried the (undocumented) rapc options -nopreverified & -noverifyerr but they don't avoid the failure.


Googling this has turned up only the following:


The rapc command-line is

rapc import=.../net-rim-api.jar codename=Xyzzy 
-midlet c:\workspace\maelstrom\Remote\Client\Midp\main\BlackBerry/deployed/debug/Xyzzy.jad


This occurs with JDE 4.3.0 & 4.6.1.


Any help gratefully received.


-- Richard

BlackBerry Development Advisor
Posts: 15,884
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: rapc reports "Fatal Internal error: NullPointerException" in "Populating"

When building the project in the BlackBerry JDE, are you building from source Java files or converting an already existing JAR file into a COD file?
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
New Developer
Posts: 2
Registered: ‎12-22-2008
My Device: Not Specified

Re: rapc reports "Fatal Internal error: NullPointerException" in "Populating"

I'm converting a .jar into a .cod.
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: rapc reports "Fatal Internal error: NullPointerException" in "Populating"

run preverify.exe with your jar file before converting it to cod file.


Specify in params path to the net_rim_api.jar library.


It will check your jar-file byte-code according to the net_rim_api.jar classes.

Posts: 23
Registered: ‎04-22-2009
My Device: Not Specified

Re: rapc reports "Fatal Internal error: NullPointerException" in "Populating"



I have a similar problem. I alsough get a NullPointerExeption at the end of the compile process but without a stacktrace.

Here is the verbouse compiler output shortened for readablitlty reasons.


Parsing classfile: C:\DOKUME~1\bigalko\LOKALE~1\Temp\rapc_3aa5a296.dir\de\prisma\bayer\trulybayer\validation\ws\client\GetValidationChain.class
Parsing classfile: C:\DOKUME~1\bigalko\LOKALE~1\Temp\rapc_3aa5a296.dir\de\prisma\bayer\trulybayer\validation\ws\client\GetValidationChainResponse.class
[endless parsings omitted]
Parsing classfile: C:\DOKUME~1\bigalko\LOKALE~1\Temp\rapc_3aa5a296.dir\de\prisma\util\fileupload\HexStringConverter.class
Parsing classfile: C:\DOKUME~1\bigalko\LOKALE~1\Temp\rapc_3aa5a296.dir\de\prisma\util\StringTokenizer.class
Parsing import: ../../../Programme/Research In Motion/BlackBerry JDE 4.7.0/lib/net_rim_api.jar(net_rim_bb_addressbook.cod)
Parsing import: ../../../Programme/Research In Motion/BlackBerry JDE 4.7.0/lib/net_rim_api.jar(net_rim_bb_addressbook_gal.cod)
Parsing import: ../../../Programme/Research In Motion/BlackBerry JDE 4.7.0/lib/net_rim_api.jar(net_rim_bb_addressbook_models.cod)
[endless imports omitted]
Parsing import: ../../../Programme/Research In Motion/BlackBerry JDE 4.7.0/lib/net_rim_api.jar(net_rim_xml.cod)
Parsing import: ../../../Programme/Research In Motion/BlackBerry JDE 4.7.0/lib/net_rim_api.jar(net_rim_xml_org.cod)
Warning!: Reference to class: net.rim.device.api.system.PersistentObject requires signing with key: RIM Runtime API
Warning!: Reference to class: net.rim.device.api.system.PersistentStore requires signing with key: RIM Runtime API
C:\d\_SVN_PROJECTS\BlackBerryJDE\TrulyBayer_BB\src\de\prisma\bayer\trulybayer\validation\ws\client\GetValidationChain.java:23: Warning!: method 'de.prisma.bayer.trulybayer.validation.ws.client.GetValidationChain.getIdentity()' not invoked.
C:\d\_SVN_PROJECTS\BlackBerryJDE\TrulyBayer_BB\src\de\prisma\bayer\trulybayer\validation\ws\client\GetValidationChain.java:27: Warning!: method 'de.prisma.bayer.trulybayer.validation.ws.client.GetValidationChain.setIdentity(String)' not invoked.
C:\d\_SVN_PROJECTS\BlackBerryJDE\TrulyBayer_BB\src\de\prisma\bayer\trulybayer\validation\ws\client\GetValidationChain.java:31: Warning!: method 'de.prisma.bayer.trulybayer.validation.ws.client.GetValidationChain.getBarcode()' not invoked.
C:\d\_SVN_PROJECTS\BlackBerryJDE\TrulyBayer_BB\src\de\prisma\bayer\trulybayer\validation\ws\client\GetValidationChain.java:35: Warning!: method 'de.prisma.bayer.trulybayer.validation.ws.client.GetValidationChain.setBarcode(String)' not invoked.
[endless warnigs omitted]
C:\d\_SVN_PROJECTS\BlackBerryJDE\TrulyBayer_BB\src\de\prisma\blackberry\gui\PrisFieldGrid.java:91: Warning!: local variable(s) { paddings } initialized but not used in: de.prisma.blackberry.gui.PrisFieldGrid.<init>()
C:\d\_SVN_PROJECTS\BlackBerryJDE\TrulyBayer_BB\src\de\prisma\gryphos\barcode\GryphosBarcodeMainScreen.java:53: Warning!: local variable(s) { horizontalLine } initialized but not used in: de.prisma.gryphos.barcode.GryphosBarcodeMainScreen.<init>(GryphosBarcodeBackBone)
C:\d\_SVN_PROJECTS\BlackBerryJDE\TrulyBayer_BB\src\de\prisma\gryphos\barcode\ProductScreen.java:153: Warning!: local variable(s) { dummy } initialized but not used in: de.prisma.gryphos.barcode.ProductScreen.setProductData(String)
Fatal Internal error: java.lang.NullPointerException


 If necessary I can provide the complet output. Any help appreciated.


Posts: 412
Registered: ‎09-12-2008
My Device: 9000 9810

Re: rapc reports "Fatal Internal error: NullPointerException" in "Populating"

bump *.


Any update on the topic ?

"Listen carefully, I shall say this only once"