Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 1,415
Registered: ‎07-30-2008
My Device: Not Specified

service book trashed on app delete?

I've gotten two reports of problems with the Service Book after deleting our browser app.

The users,

BlackBerry8330/4.3.0  and  8830/4.2.2  are both

Profile/MIDP-2.0Configuration/CLDC-1.1 VendorID/105
( Verizon IIRC)

complain that they get the following error,

" your device does not currently have any browser configuration service book entries. Please contact your service provider to enable browser on your device" after deleting but there appears to be no problem while using the app.


I look at the Service Book for a few purposes such as picking URL parameters for interface/routing selection and

problem reporting ( the code that reports errors back to me also scans the service book). I also

use persistent storage but AFAIK do nothing else that would obviously have non-local impact.


This seems to have begun when I changed the code organization from a single cod file

into a two piece app containing a shared library and an app specific cod file with only an icon and an

a subclass of a parameter class contained in the library. Beyond this, there doesn't seem to be

anything in the jad that is unusual, certainly nothing that suggests writing to the service book upon

app delete. The users have either been installing the 2-piece jad or library-only-jad OTA.

The library-only-jad has RIM-Library-Flags set to 2 while the app jad had no matching entry

( but AFAIK there hasn't ben a problem sharing the code when users attempt multiple

app downloads of different apps, the library gets updated each time but there doesn't appear

to be a problem other than wasted update ).



What kinds of things would cause this error ? Does it literally mean a service book problem

or some related issue?











BlackBerry Development Advisor
Posts: 15,888
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: service book trashed on app delete?

[ Edited ]
I doubt that this is related to removing your application.  There are no APIs available to third party applications that allow an application to modify or delete a service book record.  How was the application remove?  If they wiped their device the service books would be deleted.
Message Edited by MSohm on 12-23-2008 02:16 PM
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 1,415
Registered: ‎07-30-2008
My Device: Not Specified

Re: service book trashed on app delete?

Earlier I had noticed the one had a null email address and I asked him about it he said he was trying to clean the device and he does talk with the other guy. I'll see if I can find out. I guess there could be a security feature or

bug to wipe out the device, and I do know on my device a call to "fillEllipse" seems to act as a consistent

reset Smiley Happy They have both removed apps before but they could have tried something different, perhaps

there is an option near "modules" in the adv options menu.




Posts: 1,415
Registered: ‎07-30-2008
My Device: Not Specified

Re: service book trashed on app delete?

one of the people now says VZW has seen this come up recently, probably not related to the app

delete just a coicidence.

Thanks but I take it the carriers update the service book transprarently form time to time.