Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 39
Registered: ‎03-17-2009
My Device: Not Specified

Re: signature tool error: Unable to create a temorary directory necessary for this application

Here's what I've learned on this issue.

I was happily developing on an old Windows XP SP3 machine, with a batch build process targeting BlackBerry OS 4.0.2, 4.1.0, 4.3.0, 4.7.0, 5.0.0, and 6.0.0 (the versions where the BlackBerry API changed in a way that affects my app).  My old PC died, so I bought a 64-bit Windows 7 PC.  I am aware that http://na.blackberry.com/eng/developers/javaappdev/javaupdate.jsp calls for 32-bit Java and 32-bit Eclipse 3.5, but please bear with me, as I don't believe that that matters for the issue at hand.  This is only regarding the build process, not running the JDE for simulation. (Note to self: install old Eclipse and make it use 32-bit java for simulation.)

My batch process consists of ant and groovy inside ant, usually invoked from Eclipse (but *not* using BlackBerry plugin). It invokes rapc.exe, SignatureTool.jar, etc.  Again, it worked great on Windows XP for versions ranging from 4.0.2 to 6.0.0.

Interestingly, I was able to successfully built my 4.0.2-, 4.1.0-, and 4.3.0-targeted versions.  My 4.7.0, 5.0.0, and 6.0.0 builds all fail in the same way:  SignatureTool fails with a dialog box:

| Unable to create a temporary directory necessary for this application. |
| Directory: iHsbypAG.                                                   |
| Exiting...                                                             |
|                                +----+                                  |
|                                | OK |                                  |
|                                +----+                                  |

where the directory name changes each time.  This occurs after the "Loading Files: 75%" message but before "Loading Files: 100%".

I examined permissions and attributes of both the RIM Program Files directories and my project directories, but discerned no difference.  There are many, many files.

I tried copying the project directory to a new directory; that does not work.  I have even tried creating a new project directory manually, creating new .jdw and .jdp files manually and copying in the contents; that does not work either.

My build process runs the 6.0.0 SignatureTool, but other versions, such as 4.7.0 and 4.3.0 fail in exactly the same way.

On a somewhat related, but not as dire, note, whether SignatureTool ultimately works or not, I get the following two lines between "SignatureTool Started" and "Finding Files...":

   File could not be found.
   LogFile.txt file could not be opened for write.

Because the first line doesn't say what file it's looking for, I've got no idea what file is being referred to.  For the second line, when I look at the backups from my XP PC, I see that it's written to the bin (!) directory of the JDE Program Files directory and would contain the SignatureTool start/stop messages.


Following a tip at http://supportforums.blackberry.com/t5/Java-Development/Eclipse-error-running-signature-tool/m-p/154... from anansi on May 11, 2010, I opened up the permissions on SignatureTool.jar and the "bin", JDE 6.0.0, and "Research In Motion" folders above it, and it worked!  Also, the file-not-found and logfile.txt messages went away.  Your mileage may vary.

Here are my comments, suggestions, bug reports, theories, etc.:

1. When SignatureTool is unable to find a file, it should report the full pathname.
2. When SignatureTool is unable to open a file for write, it should report the full pathname.
3. When SignatureTool is unable to create a directory, it should report the full pathname.
4. Log files should not be written to the directory that contains executables, IMO.
5. Given that SignatureTool works as it does, the installer needs to open up permissions on more files and/or folders.

I hope my experience saves somebody else some time.

New Member
Posts: 1
Registered: ‎02-19-2013
My Device: 8520
My Carrier: vodafone

Re: signature tool error: Unable to create a temorary directory necessary for this application

If your using eclipse try change your folder.


if wont work than create new project with same source code and than try .