Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums on April 1st. BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com


Reply
Contributor
Posts: 12
Registered: ‎06-25-2013
My Device: Z 10
My Carrier: Verizon
Accepted Solution

10.2 Beta problem

I have upgraded to Blackberry 10.2 and I am trying to run a Z 10 app on my Z 10 device from the QNX development environment.

 

I am getting this error:

result::failure 533 Application-Requires-System: version 

forbidden, want (10, 2, 0, 0) have (10, 0, 10, 684)

 

I have tried generating new debug tokens, used new code signing keys, deleted and recreated the target but I am still getting the same error.  I had this problem once before and I just deleted the debug token and then the development environment prompted me to download the runtime libraries for the device or target and that solved the problem.  But this time nothing I have tried solves the problem.

 

Thanks and Best Regars

 

jvstewart

Developer
Posts: 526
Registered: ‎05-17-2009
My Device: 9900
My Carrier: ATT

Re: 10.2 Beta problem

in the gui editor of bar-descriptor.xml on the general tab there is an "api level" section. That controls that message, you can set whatever you want, or set your project api level to be the 10.1 sdk and not the 10.2.
Like all of my posts
Contributor
Posts: 12
Registered: ‎06-25-2013
My Device: Z 10
My Carrier: Verizon

Re: 10.2 Beta problem

Thanks for the reply.  That led to the answer.  I think what happened was that the settings in Window->preferences are appled to new projects but old projects have to be set using the properties from the project context menu.  Once I set the project API level the application uploaded to the device.

Developer
Posts: 526
Registered: ‎05-17-2009
My Device: 9900
My Carrier: ATT

Re: 10.2 Beta problem

Great, glad that worked. If that solved things make sure to mark the thread as solved!
Like all of my posts