Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 54
Registered: ‎05-23-2012
My Device: Developer
My Carrier: Developer

App won't run with Memory Analysis Tool

My app runs fine but has some leaks on exit (found using GAMEPLAY_MEM_LEAK_DETECTION in the GamePlay library which it uses). I want to eliminate all leaks before I submit to App World.


I want to use the Momentics Memory Analysis Tool to get the allocation traces but when I follow the instructions here my app dies on launch with:


Thread [1] (Suspended : Signal : SIG41:Real-time event 41)
_start_() at 0x199331c


If I resume the app terminates. I tried disabling GAMEPLAY_MEM_LEAK_DETECTION but got the same result.


Thanks for any help.


I know exactly where the problem *might* be.
Posts: 206
Registered: ‎05-15-2012
My Device: None
My Carrier: Telus

Re: App won't run with Memory Analysis Tool

Having the same issue.

Check out my app, Alien Flow for reddit

And of course, like my post if you found it helpful or informative!