Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

New Developer
Posts: 31
Registered: ‎03-06-2012
My Device: BlackBerry PlayBook 4G
My Carrier: AT&T

App won't start in simulator

[ Edited ]



I wanted to see if I could get my application to run in the BlackBerry simulator. I installed VMWare Player, booted the simulator, and can already compile using the "i486" toolchain, package, install and prompt it to run. I don't get "error 8" or anything like that. It seems to work... except that the application doesn't run.


I tried to pull /logs/log but it said this file didn't exist. How do I debug this?


Other than changing to the "i486" toolchain instead of "arm", is there anything else I should have to do to make my application run? It uses SDL and OpenGL ES, but it supports a software fallback. Is there anything I'm missing?


Thanks! This is an application framework, so even though it runs on my device, it would be nice to offer people the chance to run it in the simulator too, if they prefer. 


UPDATE: I noticed that I couldn't run the Browser, either, so I restarted my computer and restarted the simulator from scratch. I was able to run the browser, then tried to run one of my applications, and the window started to appear, but then closed. Afterward I could not open the Browser or my applications anymore.