Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Contributor
Posts: 17
Registered: ‎07-17-2012
My Device: N/A
My Carrier: N/A

Application built for NDK beta 2 can't be launched on Trunk-developer build.

Hi, all

 

I have built one cascade  application for devices and it runs smoothly Smiley Happy.   After I upgraded the software of devices to Trunk-developer and the application can't be launched anymore. It reports the following error.

 

ldd:FATAL: Unresolved symbol "_ZN2bb8cascades11QmlDocumentC1Ev" called from Executable

 

It seems that cascades::QmlDocument is not found on the device. I know that cascade is not stable now and I may endure some huge change before it is officially released to the public.  But QmlDocument should be one of fundamental thing if we use the QML in the C++ code, is that still unstable or has it big change in the future? How can fix that??

 

Thanks/BRs

 

Highlighted
BlackBerry Development Advisor
Posts: 683
Registered: ‎11-29-2011
My Device: PRIV
My Carrier: Rogers

Re: Application built for NDK beta 2 can't be launched on Trunk-developer build.

Use Trunk NDK.  There are enough differences between R6 and Trunk.

Contributor
Posts: 17
Registered: ‎07-17-2012
My Device: N/A
My Carrier: N/A

Re: Application built for NDK beta 2 can't be launched on Trunk-developer build.

Thanks for your so quickly response. It's my first thinking that I should use the NDK trunk, but I found that the latest release date of that was on Feb 28, 2012. The latest trunk elease of mobile software (1660) is on July.  That's my concern. Whether that NDK works on the latest release. 

 

Thanks and I will try that.

 

BRs

BlackBerry Development Advisor
Posts: 683
Registered: ‎11-29-2011
My Device: PRIV
My Carrier: Rogers

Re: Application built for NDK beta 2 can't be launched on Trunk-developer build.

If you are a RIM development partner or employee (which I assume you are, if you say you are using "trunk" builds), then you should be able to get access via your official channels.  The NDK is available on a daily basis internally.  This support forum is not intended for internal discussion unless related to the official external releases.

 

Cheers,

Sean