Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 206
Registered: ‎05-15-2012
My Device: None
My Carrier: Telus

Application does not launch on device

[ Edited ]

Unfortunately this is all I have to work off of. My application works great on the emulator. Apparently it won't even launch on a device. I failed verification with this message:

 

I am testing your app on the BlackBerry Dev Alpha, the application fails to launch. If the user selects the application icon, the app cannot launch and back to home screen. 

 I do not have a device of any kind, and I'm completely unable to test the application on a device. I have no idea what the error could be and I experience no problems running it on the emulator.

 

Does anybody have any idea where I could start looking for a problem? Anyone encounter a similar problem?

----------------------
Check out my app, Alien Flow for reddit

And of course, like my post if you found it helpful or informative!
Developer
Posts: 206
Registered: ‎05-15-2012
My Device: None
My Carrier: Telus

Re: Application does not launch on device

I seem pretty screwed on solving this without a device :/

 

I went over this page:

https://developer.blackberry.com/cascades/documentation/getting_started/tools/compiling.html

 

I had my .pro file device release settings styled the old way:

device {
    CONFIG(release, debug|release) {
        DESTDIR = o.le-v7
    }
    CONFIG(debug, debug|release) {
        DESTDIR = o.le-v7-g
    }
}

 

changed to the new way:

device {
    CONFIG(release, debug|release) {
        DESTDIR = o.le-v7
        TEMPLATE=lib
        QMAKE_CXX_FLAGS += -fvisible
    }

 

I had already changed my main.cpp to include Q_DECL_EXPORT and my .bar file entryPoint tag as QNX/Cascades.

 

We'll see if this solves the issue I guess, can't test it myself :/

----------------------
Check out my app, Alien Flow for reddit

And of course, like my post if you found it helpful or informative!
Highlighted
Contributor
Posts: 43
Registered: ‎01-05-2013
My Device: Dev Alpha
My Carrier: Telenor Hungary

Re: Application does not launch on device

Hi, if you send me your project, I can test it for you on a dev alpha device.
--------------------------------------------------------------
If my post was helpful or it was the solution for Your problem, please don't forget to give me a like, and mark my post as a solution. Thanks!