Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
Developer
Posts: 26
Registered: ‎01-06-2013
My Device: Playbook developer
My Carrier: NA
Accepted Solution

Asset requires dependency "libpps.so.1" to be included in the BAR package.

[ Edited ]

I installed the BB10 sdk, but I am doing a playbook SDK build, and in the build I'm getting lots of new warnings about system libraries after the IDE was updated:

 

Asset requires dependency "libfreetype.so.1" to be included in the BAR package.
Asset requires dependency "libGLESv2.so.1" to be included in the BAR package.
Asset requires dependency "libm.so.2" to be included in the BAR package.

 All these libs should be linked at runtime, what does it mean 'include in the BAR package' ?

 

Thanks

Developer
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Asset requires dependency "libpps.so.1" to be included in the BAR package.

That should be warning not errors. You don't have to include these libraries in your .bar file they are present on PlayBook and will be dinamically used by your app.

Developer
Posts: 26
Registered: ‎01-06-2013
My Device: Playbook developer
My Carrier: NA

Re: Asset requires dependency "libpps.so.1" to be included in the BAR package.

Alright, I guess it's just a bug in the new builder.