Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
Developer
Posts: 93
Registered: ‎02-04-2009
My Device: PRIV, Passport, Z30, Q10, Z10

BB10 NDK - refresh issues from Windows 8

I am still not able to refresh my NDK to the latest on any of my Windows  installs - ANY help would be appreciated...

 

First - I run the Gold SDK install with compatibility set for Win7 - it installs...

The shortcuts don't work - so I have to manually change to start the C:\bbndk\bbndk.bat instead... - and it works...

I can compile and pack apps...

 

But - when trying to refresh to latest 2318 build (from within the IDE)- it starts to fetch all files - and when it comes it 22% - (I guess this is where the unpacking and install of new libraries start) - the install process just stops and say 

"SDK install operation failed: An error occurred while installing the items"

 

After this - I have problems using the old install as well ... every time starting Eclipse - it tells that No SDK is installed...

 

and I have to do a re-install of the Gold version for things to work again...

 

The "flight boards" show that IDE support for Windows 8 has "landed" back in December... 

 

Does ANYONE have a solution for this?