Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Developer
Posts: 120
Registered: ‎03-13-2012
My Device: Playbook, Dev Alpha C, Q10, Z10, Z30
My Carrier: T-Mobile

BB10 Simulator doesn't react to swipe down

I'm witnessing some unexpected BB10 Simulator (BB10_0_09.2318) behavior that I would like some help with to either dismiss as harmless or change my code to make my app work proprerly.

 

I'm coding with the Momentics IDE Native SDK for 2.0 and would like to use the same BAR file for both the Playbook and BB10.

 

With an older BB10 Dev Alpha Simulator (it resembles the Playbook in appearance), when I go to run the app through the IDE as Simulator-Debug everything works as expected, just the screen size is different.  Specifically, the app icon shows up on the simulator, it starts and functions as expected, and when I swipe down to get to my options dialog (api native dialog box), it shows up and I can choose the buttons and have the app do all that I can do on the Playbook.

 

With the .2318 sim, it starts up just fine and I get the screen and action that I expect, but when I swipe down, nothing happens.  The only thing I can do is thumbnail the app and if I wish, close it. 

 

The other odd bit is that when I launch the app from the icon in the simulator, the screen is distorted, as in stretched, from side to side.  When I download and launch again from the IDE, it looks fine.

 

I only have the sim to work with and not the device.

 

Any ideas what I might be doing wrong, or what I might try?

 

Thanks.


Details:

Win 7
VM Workstation 6.5-7.x
Dev Alpha Simulator BB10_0_09.2318

Highlighted
Developer
Posts: 120
Registered: ‎03-13-2012
My Device: Playbook, Dev Alpha C, Q10, Z10, Z30
My Carrier: T-Mobile

Re: BB10 Simulator doesn't react to swipe down

Update:

 

You must call

 

screen_create_window_group();

 

in order to use dialogs.

 

This wasn't the case previously.

 

I still get distortion if I run the app again in the simulator.  Don't know what that's about.

 

Also, the dialog boxes don't work in the same manner as before.  If you have too many buttons, the last ones won't show and any message text in the alert_dialog won't show.  This is a real conundrum for me as I used to give instructions for what each of the buttons did in the message text.  I suppose it's because the sim is for the phone and things are very tiny, so they only allow so much for real estate.

 

Got some thinking and rearranging to do.