Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 293
Registered: ‎10-15-2012
My Device: bb10 developer
My Carrier: Orange
Accepted Solution

Beta4 - cannot preview QML

I just installed the latest BB10 Cascades NDK (beta4)

 

When I launch the NDK, I get the following message after I select the workspace I was working on in beta3:

 

"The QML preview is not available.


java.lang.UnsatisfiedLinkError: com.rim.tad.tools.qml.sim.CsQtApplication.nCreate(Ljava/lang/StringSmiley WinkV

"

 

My workspace loads, and I can compile + deploy to the new beta4 simulator. But, I cannot open an QML file in the IDE - the IDE hangs and I have to forcibly terminate it. 

 

Is there something else I need to install to get this new NDK working?

 

thanks

 

thanks

Developer
Posts: 828
Registered: ‎10-16-2012
My Device: Red Z10
My Carrier: Rogers

Re: Beta4 - cannot preview QML

change it to .1101

 

beta4fix.png

Developer
Posts: 410
Registered: ‎06-03-2010
My Device: Z10 Red
My Carrier: Free

Re: Beta4 - cannot preview QML

Change what to ".1101"?

Highlighted
Developer
Posts: 293
Registered: ‎10-15-2012
My Device: bb10 developer
My Carrier: Orange

Re: Beta4 - cannot preview QML

It took me a moment to figure this out also

In the IDE settings we need to change the selected SDK version from the old SDK (10.0.9.386) to the beta4 SDK (10.0.9.1101)

You can do this from the main menu:

Window -> Preferences -> QNX -> SDK Selection

Just select the appropriate SDK from the dropdown list!