Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
New Developer
Posts: 17
Registered: ‎04-14-2013
My Device: Simulator
My Carrier: Simulator
Accepted Solution

BlackBerry 10 supported devices

Hi,

 

I recently got a rejected for an app because it is said that it doesn't work on the Playbook. As a minor note, I'm not a native english speaker but the reply I got from support :

 

"The PlayBook appear as supported device when you select the minimum OS for your app because the PlayBook will not support OS 10 later on. "

 

Uhm... sounds a bit contradictory to me and I assume it's the lack of english skills.

 

So, since I don't have a playbook, does it support running 10.0 (native) apps ? Does the reply above actually meant it will support them at a later date but not currently ?

 

Anothert side question, if I build the app with the 10.1 SDK (I did this by mistake, the simulator which was of 10.1 asked for an app built with the 10.1 SDK ), will it still run on 10.0 devices ? or does it require a device with 10.1 installed ?

--------------------------------------------------------------------------
www.facebook.com/relativegames - My Apps
Developer
Posts: 1,524
Registered: ‎12-18-2012
My Device: Z30, Z10 LE, DevAlpha C, PlayBook

Re: BlackBerry 10 supported devices

PlayBook doesn't support BB10 and requires separate binaries. Probably you've chosen PlayBook when uploading the app. Cascades may be ported to PlayBook in the future, but no dates were announced yet.

 

If you aren't using any 10.1 specific API's, most likely it will work. They're binary compatible. But to be safe, it's better to build using older SDK.

 


Andrey Fidrya, @zmeyc on twitter