Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
New Developer
Posts: 30
Registered: ‎11-02-2010
My Device: playbook

Can not start debug on device

Hi all,

 

i am starting to debug on device (z30 with os 10.2.1.2102) and it is not working at all.... It has worked for 5 minutes and then I don't know why it start to fail and fail and fail again...

 

I have an error :

Error in final launch sequence

Cannot prepare and download the binary

Read timed out

Read timed out

 

and in the console:

 

639,462 8source .gdbinit

639,462 &"source .gdbinit\n"

639,463 &".gdbinit: No such file or directory.\n"

639,463 8^error,msg=".gdbinit: No such file or directory."

639,463 (gdb) 

639,464 9-file-exec-and-symbols /Users/benj/Documents/BB/arm/o.le-v7-g/

 

i try to restart my mac / momentics / z30 it has works once and now it's over...

 

I am desperate if anyone has an idea ?

Retired
Posts: 85
Registered: ‎05-25-2012
My Device: Limited Edition Z10
My Carrier: Bell

Re: Can not start debug on device

New Developer
Posts: 30
Registered: ‎11-02-2010
My Device: playbook

Re: Can not start debug on device

there are no solutions on this thread, someone say swith off the wifi so you can't use network, and the guy says error still the same .... so no solutions at all.

 

My solution: reboot phone, mac, disconnect usb, pray hit debug key 35 times and maybe it works... such a pleasure to work ...

Retired
Posts: 85
Registered: ‎05-25-2012
My Device: Limited Edition Z10
My Carrier: Bell

Re: Can not start debug on device

Try changing your debug configuration options:

 

  • Project Properties -> Run/DebugSettings
  • Edit the launch configuration for the selected device
  • Click the Upload tab
  • Select "Only upload files that have changed"

 

New Developer
Posts: 30
Registered: ‎11-02-2010
My Device: playbook

Re: Can not start debug on device

so this option was already set.... So I changed it to deploy Bar file and it seems to work ... until next time i think ! thank you for your help !