Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 1,177
Registered: ‎03-20-2013
My Device: Red LE Developer Z10
My Carrier: Fido

Can't debug on physical Z10

In the early days of developing my app back in March I was using Momentics 10.0.9 and running BB OS 10.0 n my Z10 and UI was able to debug code on my physical device. Over time I have migrated to Momentics 10.1 and then 10.2, and likewise have upgraded the Z10 to new OS versions. It is currently running


Somewhere along the way I lost the ability to debug on the Z10, although I can still debug fine on the simulator. The app starts but remains stuck on the splash screen. The debugger never even reaches main(). Momentics 10.2 forces you to use the correct SDK for your device, but even when I try this with Momentics 10.1 with the SDK I am unable to get my app to debug on the Z10. If I RUN the debug version from the IDE on the Z10 it works fine, and outputs console messages to the IDE, but if I try to DEBUG the same code it just hangs up.


For a while after this started happening I could work around it by RUNning the debug version of the app on the phone, then attaching a debug session to the already running app. This helped, but it was only half a solution since the message loop has to be running for this to work, which precludes debugging any startup code. In any case, unfortunately even this trick doesn't work anymore.


A few days ago I did a full OS wipe/reinstall on the phone to again, but I still can't debug. Has anyone else experienced this, and more to the point, has anyone figured out a solution? I really hate not being able to debug my complicated app on a physical device.

Developer of Built for BlackBerry certified multiFEED RSS/Atom feed reader and aggregator.  multiFEED Icon

Play nice: Clicking Like Button on posts that helped you not only encourages others to continue sharing their experience, but also improves your own rating on this board. Also, don't forget to accept a post if it solves your problem or answers your question.
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Can't debug on physical Z10

Did you read this thread I posted a while back it may help...



If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.