Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
New Developer
Posts: 13
Registered: ‎01-22-2013
My Device: Dev Alpha
My Carrier: none

Cascades MediaPlayer do not play formats that are supposed to be known.

I am trying to play

 

http://tv3catwmlive.fplive.net/tv3cat-live/stream_CatRadio_WM

 

with the cascades qml mediaplayer and it does not work.

 

The problem is that if you connect with mplayer it says the stream is ASF fwith wma, and that is supposed to work with BB10, so ... where is the problem?

 

I am testing it in a real Dev Alpha device with last firmware (that I know of).

 

Here you have what mplayer says:

 

Playing http://tv3catwmlive.fplive.net/tv3cat-live/stream_CatRadio_WM.
Resolving tv3catwmlive.fplive.net for AF_INET6...

Couldn't resolve name for AF_INET6: tv3catwmlive.fplive.net
Resolving tv3catwmlive.fplive.net for AF_INET...
Connecting to server tv3catwmlive.fplive.net[199.93.35.49]: 80...

STREAM_ASF, URL: http://tv3catwmlive.fplive.net/tv3cat-live/stream_CatRadio_WM
Resolving tv3catwmlive.fplive.net for AF_INET6...

Couldn't resolve name for AF_INET6: tv3catwmlive.fplive.net
Resolving tv3catwmlive.fplive.net for AF_INET...
Connecting to server tv3catwmlive.fplive.net[199.93.35.17]: 80...
Resolving tv3catwmlive.fplive.net for AF_INET6...

Couldn't resolve name for AF_INET6: tv3catwmlive.fplive.net
Resolving tv3catwmlive.fplive.net for AF_INET...
Connecting to server tv3catwmlive.fplive.net[199.93.35.49]: 80...

Cache size set to 180 KBytes
Cache fill: 17.39% (32058 bytes)   

ASF file format detected.
[asfheader] Audio stream found, -aid 1
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
AUDIO: 44100 Hz, 2 ch, s16le, 96.0 kbit/6.80% (ratio: 12003->176400)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...

 

Could anybody send me a tip on what is going on?

 

Tanks.