Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
Posts: 17
Registered: ‎09-08-2012
My Device: blackberry dev alpha
My Carrier: Airtel

Could not find Qmake configuration directoryCould not find qmake configuration fileUsing OS scope before setting MAKEFILE_GENERATOR

[ Edited ]

i am using windows 7 32 os & XML editor to make codes... File runs successfully on simulator... But when it comes to device... Actually I am using blackberry 10 dev alpha.... The app will be installed on device but it can't be opened... It shows error 7 on device... Then I notice "Could not find qmake configuration directoryCould not find qmake configuration fileUsing OS scope before setting MAKEFILE_GENERATOR" on console...
can anyone have a solution???

Thanks in advance 
sachin

Developer
Posts: 222
Registered: ‎11-05-2011
My Device: Z10
My Carrier: Beeline

Re: Could not find Qmake configuration directoryCould not find qmake configuration fileUsing OS scope before setting MAKEFILE_GENERATOR

If you can't build and run app try look on your windows account name. If your windows account name have cyrrilic or non-english letters, create a secondary account with only english letters name. Delete your cascades NDK, reboot, enter into new windows account. Install Cascades SDK. And run! After first run you can make builds and runs!

Developer
Posts: 222
Registered: ‎11-05-2011
My Device: Z10
My Carrier: Beeline

Re: Could not find Qmake configuration directoryCould not find qmake configuration fileUsing OS scope before setting MAKEFILE_GENERATOR

But usually I don't have problems...I found that message in my console too. Maybe errors in code?
Contributor
Posts: 17
Registered: ‎09-08-2012
My Device: blackberry dev alpha
My Carrier: Airtel

Re: Could not find Qmake configuration directoryCould not find qmake configuration fileUsing OS scope before setting MAKEFILE_GENERATOR

even basic codes have this problem... but it runs on simulator.....
but when it comes to device .... it wont do!!!! 
i have re installed windows... it didnt even works...Smiley Sad

Highlighted
Retired
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: Could not find Qmake configuration directoryCould not find qmake configuration fileUsing OS scope before setting MAKEFILE_GENERATOR

Hi there!

 

Which versions are you using on your device and qde?

Could you provide us with the complete error log?

 

Thanks,

 

Martin