Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Debugging Frustrations

Switch to WiFi only set up (disconnect from USB) and run Wireshark -)

Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: Debugging Frustrations

BGmot has a good idea. Some other tests that could prove useful:

1) Try some other projects such as the built-in samples. Do they debug more reliably?

2) Do you have another PlayBook available for testing? If not please try a simulator. Does debugging improve?


When the failure occurs, does the new application still install successfully to the PlayBook? If not:

3) Does deploying applications from the command-line succeed consistently (both over WiFi and USB)?

Goodbye everybody!
New Developer
Posts: 29
Registered: ‎02-26-2012
My Device: Playbook, Bold 9900
My Carrier: Telus

Re: Debugging Frustrations

1) I tried the samples and just a plain Hello World, they are just as unreliable

2) I don't have a second playbook.  I tried the simulator and it is 100% reliable


When the failure occurs the application has been installed it just fails at the final moment. 


I tried a wifi target and it is the same behaviour  as USB.  Using wireshark I do see one thing different between a good run and a failed run. just before the IDE pops up the error this shows up in wireshark:


696.503190 TCP https > 61640 [RST] Seq=2458 Win=0 Len=0


I haven't tried command line deployment tests yet.



Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: Debugging Frustrations

Same problems here. Wifi on PB is off, same errors. I did not tried through wifi because router is damaged. Also. tried to manually sideload bar file from my project with bbh tool, and again it fails.

What I found so far is:
- bar created during compile/run is probably somehow damaged
- going in debug perspective and relaunch works without problems (even changes to the code are recompiled and new updated bar is created)

I'll try with simulator to see whether the same happens.

Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Debugging Frustrations

>696.503190 TCP https > 61640 [RST] Seq=2458 Win=0 Len=0

From here we can see that PlayBook terminates connection, not good. Can you send me .pcap file generated by Wireshark when this happens and when everything is good?