Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 12
Registered: ‎10-06-2012
My Device: cuenicks
My Carrier: eventphone

Design Mode disabled / greyed out on linux

I can't access the QML design mode in Momentics.  All icons except "Source mode" are greyed out.  I get the same result whether I load a sample or create a new file.


Some info:



Version: 10.0.9
Build id: v201209241008


Operating System:

Debian GNU/Linux 6.0.6 (squeeze)



Are there any logs I could provide?  I don't know how to get to them and there's nothing on stderr.

Posts: 292
Registered: ‎07-25-2008
My Device: Passport

Re: Design Mode disabled / greyed out on linux

[ Edited ]

Design mode kinda-sorta worked in Linux in the first beta (R4).  It was quite buggy though, and had a lot of library dependency issues.  But it was there, and could be made to work.  Many of us reported bugs to RIM, describing the problems.


As a result, RIM decided it was easier to just use this as justification for disabling QML preview mode in Linux (from beta 2 / R6) onward, rather than to actually fix the issues.


So yeah, for the time being, Linux users don't get QML preview.


Also, FYI, don't publicly admit to RIM that you're running any distro other than Ubuntu.  Even if you find issues that aren't distro-specific at all, they'll just close your issues as "won't fix, unsupported distro, take a hike" without looking at them for more than 30 seconds.  This is why I keep at least one of my machines running Ubuntu, just in case I need to report bugs.


P.S. Sorry if I have a bit of a chip on my shoulder about this.