Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Developer
Posts: 543
Registered: ‎12-23-2010
My Device: Z10
My Carrier: Airtel
Accepted Solution

Device camera not functioning after updating it to Golden SDK!

Hi All,

 

In my device(Dev Alpha A) Camera is not functioning after updated it to Golden SDK,

I need Cam in my app,

Any suggestion?

 

Thanks. 

Developer
Posts: 16,997
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Device camera not functioning after updating it to Golden SDK!

re-install with the desktop tool
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 243
Registered: ‎07-22-2011
My Device: BlackBerry Z10
My Carrier: AirTel

Re: Device camera not functioning after updating it to Golden SDK!

Hi pradeep,

 

For my device also having same problem, at the time of updating total 61 modules downloading is coming previously(Beta 1,2,3) it is 55 only you also face same number?

 

If you found any solution plz share to me also.

 

Thanks in advance

 

Regqards,

Lakshman k

----------------------------------------------------------
Feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.

Developer
Posts: 543
Registered: ‎12-23-2010
My Device: Z10
My Carrier: Airtel

Re: Device camera not functioning after updating it to Golden SDK!

Thanks for reply Simon,

 

I will try and let you know.

 

 

Thanks.

Developer
Posts: 1,746
Registered: ‎04-08-2010
My Device: Passport Silver, PRIV
My Carrier: Telekom.de, O2, Vodafone

Re: Device camera not functioning after updating it to Golden SDK!

just tried.... Camera is working in my app

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development native Mobile Business Apps
BlackBerry 10 | Qt Mobile (Android, iOS)
Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org
mobile-development: http://appbus.org Twitter: @ekkescorner
Regular Contributor
Posts: 54
Registered: ‎07-15-2010
My Device: Not Specified

Re: Device camera not functioning after updating it to Golden SDK!

Yeah, I can confirm that after upgrading to GOLD the Camera is working perfectly on my application, just like ekke.

 

You could do a security wipe and start over (but note that it takes a long time to do so, about 1.5 hours).

Developer
Posts: 543
Registered: ‎12-23-2010
My Device: Z10
My Carrier: Airtel

Re: Device camera not functioning after updating it to Golden SDK!

How can I do security wipe?

 

With desktop tool?

 

Sorry for my question.

 

Thanks.

Regular Contributor
Posts: 54
Registered: ‎07-15-2010
My Device: Not Specified

Re: Device camera not functioning after updating it to Golden SDK!

In fact is quite straightforward to do a security wipe, and you can do it from the device itself (note that you'll need the computer to restore it to the original state). Just follow the next steps:

 

1. Enter in Settings

2. Enter in Security and Privacy

3. Enter in Security Wipe

4. Type 'blackberry' and then press the Delete Data button

5. After your device has been wiped, connect it to your computer

6. BlackBerry Desktop Software will inform that it couldn't connect to the device. Click on Retry

7. Now the missing modules will be downloaded. After that the device will restart having the factory settings

 

I hope it helps,

Developer
Posts: 40
Registered: ‎04-01-2009
My Device: Torch 9810
My Carrier: Rogers

Re: Device camera not functioning after updating it to Golden SDK!

[ Edited ]

Stock camera app doesn't work on my Alpha A after update to 10.0.9.1675.  The viewfinder is black and the app doesn't exit properly (the icon remains greyed-out).

 

I did a security wipe and reinstalled the OS with Desktop Software.  I am going to try reinstalling with Autoloader...

 

Needless to say that my app that relies on the camera behaves exactly the same way as the stock camera app.

 

EDIT:

I tried reinstalling with Autoloader with the same negative result: the camera app still doesn't work.

Developer
Posts: 243
Registered: ‎07-22-2011
My Device: BlackBerry Z10
My Carrier: AirTel

Re: Device camera not functioning after updating it to Golden SDK!

Hi all,

 

For me also having same problem, can any one suggest me to slove this problem.

 

Thanks in advance.

 

Regards,

Lakshman K

----------------------------------------------------------
Feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.