Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 28
Registered: ‎07-17-2012
My Device: LE / DevAlphaC
My Carrier: vodafone
Accepted Solution

Error around line 578

hey guys 

 

i have an issue when running my app

 

the console showes this error

 

slogger2 buffer handle not initialized. ../../lgmon_api.c, logEvent(), around line 578!

 

 

strangely it is up running but no idea where that error comes from - a week ago when I last modified my app everything has been fine. . .and now this. . . any idea what this means?

interested in current apps?

http://appworld.blackberry.com/webstore/vendor/58298
Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Error around line 578

It appears for most people, and we're ignoring as it has no apparent negative effect.

I think it's just a leftover bit of internal debugging support code. They either removed the initialization for some logging that's still happening in at least one place, or they rearranged some code and managed to have it try logging something before the corresponding initialization took place.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
New Developer
Posts: 28
Registered: ‎07-17-2012
My Device: LE / DevAlphaC
My Carrier: vodafone

Re: Error around line 578

ah nice so I just dont have to care about it Smiley Very Happy good to know

 

interested in current apps?

http://appworld.blackberry.com/webstore/vendor/58298
Developer
Posts: 52
Registered: ‎03-29-2012
My Device: Playbook, Dev Alpha
My Carrier: Telus

Re: Error around line 578

[ Edited ]

There's one negative effect for me... no console log! 

Edit: 
NVM... I forgot to add the qInstallMsgHandler