Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 22
Registered: ‎03-22-2012
My Device: Playbook, Z10, Z30, Q10, Passport
My Carrier: T-Mobile

Re: Error code 30242 when buying a digital good

[ Edited ]

We are having the same problem with IAP, here is our scenario:

Developed with NDK 2.0.1, exported with Momentics 2.0.0 on a Win 7 x64 machine.
Device: Playbook OS Version

We followed the IAP recipe example very closely (https://developer.blackberry.com/native/documentation/recipe_payment_1935322_11.html).

The App is up in the vendor portal and in draft status, so are the IAP items.
The used SKUs and IDs are correct . We have in fact double and tripple checked them.

Here is how it fails:

1. Create sandbox user in vendor portal
2. Open AppWorld, swipe and type "tst"
3. Open browser go to the url of the app -> redirects to AppWorld
4. Downloading the App
5. Starting the installed App
6. Trigger IAP
7. Login with the sandbox account -> "Authenticating" for about 10 Sec.
8. Buy menu is shown with the correct, icon, text and price (our guess is that this means that the ids are correct)
9. press Buy -> "Processing..." for about 10 Sec.
10. Error 30242

What we have tried so far:
- Installed from AppWorld, Installed using USB or Wifi, Installed Debug Version.
- Reboot and/or reset device and reinstalled the app.
- All kinds of variations of the paymentservice_purchase_request(...) function, with ID and SKU , with ID only, with SKU only, with all parameters set, without them, ...
- info: when debugging with "paymentservice_set_connection_mode(true);" everywhing works just fine
- verified that the sandbox user has valid credit card data (in case RIMs backend tries to check that even in sandbox mode)
- removed the user from the sandbox and tried to make a real purchase- > same error.
- tried to buy IAPs with our ID in other Apps (e.g. Radiant Defense) -> same error.

Our wild guesses why it´s not working:
- IAPÜ in general does not work on our account / device but will work with other devices...
- It doesn´t work from our country (Austria)
- The IAP sample recipe is faulty and/or we are missing something essential.
- Our App and IAPs need to be in released state even though the documentation claims otherwise.
- It doesn´t work with Sandbox users at all

The only thing we have not yet tried is to actually release the app (which would be nonsene without working IAPs).

Anyone, any ideas?
An official statement from RIM on these 30242 errors would be nice!

Visit us at http://games.modalog.at and http://modernstark.com