Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 18
Registered: ‎11-30-2011
My Device: various
My Carrier: rogers,telus

Grey page during navigation

There seems to be a rendering issue in Cascades when multiple navigation animations are running at the same time (e.g. closing one sheet and simultaneously opening a dialog).

 

The page below the sheet is rendered as a blank grey box until the sheet animation finishes, then it displays correctly.

 

I'm seeing this behaviour on a Z30 running 10.2.1.537

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Grey page during navigation

you can probably avoid that by first pushing/opening the displayed page/sheet, then removing the other behind that.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
New Developer
Posts: 18
Registered: ‎11-30-2011
My Device: various
My Carrier: rogers,telus

Re: Grey page during navigation

Yes, I've done that workaround in a few places (e.g. connect(sheet, SIGNAL(closed()), dialog, SLOT(open())).

 

However, in other places the second action is a few indirect signals away (e.g. finishing a flow in one sheet alters a higher level application state, which causes an existing signal connection to navigate somewhere) and neither page/sheet is aware of the other.

 

Refactoring in some cases may be possible, but it would increase coupling and duplication (e.g. instead of closing a sheet and navigating to an existing page (which can be triggered from multiple sheets/flows), push the same page inside each of those sheets).

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Grey page during navigation

if you want to report it as a bug i have already given you the bugtracker link in your other post.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Highlighted
New Developer
Posts: 18
Registered: ‎11-30-2011
My Device: various
My Carrier: rogers,telus

Re: Grey page during navigation