Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 29
Registered: ‎04-03-2013
My Device: BB10
My Carrier: Simulator
Accepted Solution

How to install my .bar (version 10.1.0.1483 ) to Z10 (10.0.10.261) ?

Hi All,

 

I received error on version compability when I install .bar from OS 10.1.0.1483 to Z10 10.0.10.261.

May I know if i update Z10 software release, will the OS turn to 10.1.0.1483?

 
Thanks

Developer
Posts: 16,984
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: How to install my .bar (version 10.1.0.1483 ) to Z10 (10.0.10.261) ?

you should compile with a version equal or lower to the target device, so 10.0 for the z10 and q10, and 10.1 only if it is q10 only.

there is no official 10.1 for the z10 yet, but it will come. you cannot be sure when providers will offer the update though, and unless you need the 10.1 apis there is no reason to build your release with it.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 29
Registered: ‎04-03-2013
My Device: BB10
My Carrier: Simulator

Re: How to install my .bar (version 10.1.0.1483 ) to Z10 (10.0.10.261) ?

Hi simon_hain,

 

Thanks for the suggestion.

 

I read somewhere that the 10.1 Gold release can support both (Z10 and Q10) deployment.

If I build it from 10.0 SDK, does 10.0 SDK support for Picker and MapView as my app are included these 2 features?

 

Thanks.

Developer
Posts: 16,984
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: How to install my .bar (version 10.1.0.1483 ) to Z10 (10.0.10.261) ?

All API components have a "since" field that tells you the API level.
Picker has "since 10.1", so it is not supported on 10.0

That means you either have to use something else or release with 10.1 and accept that your app won't be available for the z10 until it is updated to 10.1.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 29
Registered: ‎04-03-2013
My Device: BB10
My Carrier: Simulator

Re: How to install my .bar (version 10.1.0.1483 ) to Z10 (10.0.10.261) ?

Hi simon_hain,

 

Thanks for your reply.

By the way, may I know where to check the components "since" field beside the release document from blackberry.com? As I need to check the Map "since" field version.

 

Millions Thanks.

 

Developer
Posts: 16,984
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: How to install my .bar (version 10.1.0.1483 ) to Z10 (10.0.10.261) ?

https://developer.blackberry.com/cascades/reference/bb__cascades__maps__mapview.html

Since: BlackBerry 10.0.0
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Highlighted
Developer
Posts: 29
Registered: ‎04-03-2013
My Device: BB10
My Carrier: Simulator

Re: How to install my .bar (version 10.1.0.1483 ) to Z10 (10.0.10.261) ?

Hi simon_hain,

 

Millions thanks for leading way to solve my problem.