Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 1,163
Registered: ‎03-20-2013
My Device: Red LE Developer Z10
My Carrier: Fido

Re: Is this a Q10 bug?

[ Edited ]

Yeah, that's annoying. More than once I've had readers complain that I forgot to attach the images or had made them private, when in fact they just hadn't been approved yet.

 

I am using Momentics 10.2 for a complete ground-up rewrite I'm in the midst of, but my live app is still sitting in my Momentics 10.1 workspace. I had serious problems when I upgraded from Momentics 10.0 to 10.1, having to hand-edit many configuration files so my app would compile with 10.1, so I am hesitant to migrate a live app to Momentics 10.2. It seems that 10.0 added just about every library available to the default project template, and when 10.1 came out many of them no longer existed. Even though I finally managed to edit the config sufficiently for a clean build with 10.1, I recently discovered that my app had over 20 more libraries included that it didn't use. One of them was the cause of a nagging "attempt to free unallocated memory" message on app shutdown. I eventually got the library list down to just three additional libraries beyond the core Cascades one. The Momentics 10.0 added over 30 unneeded libraries without my knowledge. I did notice that Momentics 10.2 is much better behaved, only including the core libraries in the new project template.

 

I'll look for the newer simulator though and retest. Of course, the problem is that in many parts of the world user are stuck on 10.0 or earlier 10.1 OS releases by their carriers.



Developer of Built for BlackBerry certified multiFEED RSS/Atom feed reader and aggregator.  multiFEED Icon

Play nice: Clicking Like Button on posts that helped you not only encourages others to continue sharing their experience, but also improves your own rating on this board. Also, don't forget to accept a post if it solves your problem or answers your question.
Developer
Posts: 1,163
Registered: ‎03-20-2013
My Device: Red LE Developer Z10
My Carrier: Fido

Re: Is this a Q10 bug?

[ Edited ]

Boy, they sure don't make it obvious where to find older simulator builds, do they. 

 

You are, of course, correct. Just tested with the 10.1.0.4780 simulator, and they have indeed fixed the back button icon problem.

 

BTW, got a couple of emails a few hours ago, the most recent of which reported that the bug I reported has been assigned, so we'll see if it goes anywhere this time.



Developer of Built for BlackBerry certified multiFEED RSS/Atom feed reader and aggregator.  multiFEED Icon

Play nice: Clicking Like Button on posts that helped you not only encourages others to continue sharing their experience, but also improves your own rating on this board. Also, don't forget to accept a post if it solves your problem or answers your question.