Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 26
Registered: ‎04-11-2012
My Device: BlackBerry Play book
My Carrier: BlackBerry

Issue with sound/audio looping

Hi

 

I am working on sound/background music for a game, for sound effects I have used openAl and ogg vorbis and sound effects are working really well, and for background music I am using mmrenderer api, although its working fine except some looping issues, for looping I did used solution specfied in following thread

 

http://supportforums.blackberry.com/t5/Native-Development/Multimedia-renderer-REPEAT-LOOP-Audio/td-p...

 

that is by using input parameter "repeat"

 now issue is audio is being looped but there is a little delay of approx 1 sec between two consective iterations, I am using .wav files.

 

can someone suggest be some solution to this..

 

any help would be highly appreciated 

 

Regards

Ahsan

Retired
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: Issue with sound/audio looping

Hey there,

 

Have you taken a quick peek at this thread? It may be of use to you:

 

http://supportforums.blackberry.com/t5/Cascades-Development/OpenAl-stopping-sound/m-p/1786117/highli...

 

Martin

 

Highlighted
Retired
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: Issue with sound/audio looping

Hi, have you made any progress?