Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 34
Registered: ‎12-20-2010
My Device: DevAlpha Beta 2
My Carrier: Orange
Accepted Solution

Logs with on Mac OS



I just swithed to the Beta 3 qde to continue the dev on my bb10 cascade application.

Everything work well (can compile and deploy all the sample apps etc...).

However, obviously, my application that I started with Beta 2 doesn't.

I'm currently working on it to make it work but I'm facing a problem. All my logs don't show up in the console.

Here is how I manage the logs with beta2 : qDebug() << "connectSelected";

However, my console stays empty.


It's really difficult for my to debug the problems since the only info I get when my app crash are things like this :


Process 62890184 (Marmiton) terminated SIGSEGV code=1 fltno=11 ip=786f0914(/base/usr/lib/libbbcascades.so.1@_ZN2bb8cascades8ListView12scrollToItemERK5QListI8QVariantENS0_15ScrollAnimation4TypeE+0x7bb) mapaddr=000e7914. ref=00000010


Do somebody have a solution for that ?


Thank you!

Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Logs with on Mac OS

Please use the forum search feature. Trying "logging" in the search box will show you a half dozen threads on the topic, many of which also have links to the release notes which cover this change.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Posts: 34
Registered: ‎12-20-2010
My Device: DevAlpha Beta 2
My Carrier: Orange

Re: Logs with on Mac OS

OK, thank you.