Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Contributor
Posts: 7
Registered: ‎12-08-2011
My Device: Playbook
My Carrier: Rogers

Min. OS required for native NDK apps

I'm about to submit a native application to App World. When adding a release, what do I put for the Min OS? Is 1.07 the minimum version required or is it acceptable to put 1.0 there?

 

Thanks,

 

Mark

BlackBerry Development Advisor
Posts: 417
Registered: ‎10-27-2010
My Device: PlayBook

Re: Min. OS required for native NDK apps

It is not going to work on 1.0, since most of the API was interoduced in 1.0.7. If you really want to set it 1.0 you have to find device that has this version on and test it on it.

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Min. OS required for native NDK apps

I don't think I've seen a single 1.0.7 amongst my last 500 or purchasers of Battery Guru... everyone has upgraded.

I doubt you need to worry about 1.0.7, and certainly nothing before it.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!