Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 29
Registered: ‎11-14-2008
My Device: Not Specified

Momentics 10 crash when creating debug token; opensuse 13.1; other bugs

For background, consider me a newbie. OS is opensuse 13.1 64 bit.


I downloaded Momentics 10. The installation went fine, but life is always ugly on linux when you install a binary, and Momentics was no exception. It took me a lot of hacking not to get it to crash when starting up. it turns out Momentics is particular to the desktop theme, and apparently this is not all that unique.I had to set the GTK2 and GTK3 to Adwaita to get Momentics to not crash upon start up.  This is in KDE3.


That said, Momentics never sees my phone via USB.  I can put the phone is "usb drive mode" and transfer files just fine. For the IDE, I put the phone in developer mode. I can ping the phone just fine:

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.060 ms
64 bytes from icmp_seq=2 ttl=64 time=0.034 ms

 I turned off the firewall for test purposes and Momentics stil can't find the phone via usb. I put the usb "ethernet" into the local zone and turned the firewall back on for security since it made no difference.


Here is the ifconfig on the usb ethernet.

enp0s20u8 Link encap:Ethernet  HWaddr 42:6F:2A:D4:23:F7  
          inet addr:  Bcast:  Mask:
          RX packets:77 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:16031 (15.6 Kb)  TX bytes:4560 (4.4 Kb)



That said, Momentics can find my phone via wifi. OK for now, but kind of annoying since I will always need a router until the USB issue is solved.


Note that you can't attempt a wifi coneection the first time you fire up Momentics.The only options are USB and simulatior. Since I own a Z10, I didn't want to bother with the simulator, but I did get Momentics to download the 10.2 SDK (I am anticipating the official release of 10.2). Trawling the forum, I learned that the SDK goes on the user account, while the binary of course is installed as root. This really should be documents in the installtion tarball or the download page.


You can instruct Momentics to use the simulator, but uncheck the box so that it only attempts to download the SDK. The program notices the SDK is installed and then just goes into a "restart" mode.  [Obviously if the USB problem could be solved, I wouldn't have to do this.]


Conversely, you can cancel the SDK download once you have it installed. Thus I can then "get into" the IDE. Using the pull down "manage devices", I have the choice of USB or wifi. Running usb, I get the message "Cannot connect!  Device disconnected or not detected."  Choosing wifi and doing the obvious, I get the message "You have complete signing registration."


The next step is to create the debug token. On a previous pass, I managed to get the "secure storage" to work (be created), so I enter the password. I then get the really useful message  "'Operation' has encountered a problem. An internal error occurred during "Operation".  The detail button yields: An internal error occurred during: "Operation".
java.lang.NullPointerException" Note that no error message shows up in the terminal windows that I used to launch qde.


For completeness, I ran "check for updates." None were found. The "about" yields:

Momentics® IDE for BlackBerry
Version: 2.0
Build id: v201310251603

 Since I amrunning 64 bit linux and this binary is 32 bits, possibly I need some 32 library installed. Opensuse runs open jdk rather than Oracle java, but I think Momentics embeds the java in the binary since I saw it uses java 6, while I am on java 7 within opensuse.








Let's start with the "other bugs"

BlackBerry Development Advisor
Posts: 15,814
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Momentics 10 crash when creating debug token; opensuse 13.1; other bugs

I'm going to start this with a disclaimer that we don't officially support opensuse (Ubuntu is supported), but I'll try to help with the debug token creation issue.  Let's try creating one from a command line, which should show the error.  To start off with, run bbndk-env_10_#_#_#### (#'s will match the version of SDK you have installed), which is located in your NDK installation directory.  Then run the following command:


blackberry-debugtokenrequest -storepass <password> -deviceid <device-id> <debug-token-bar-file>

 device-id refers to the PIN of the device, which can be seen in Settings -> About.


Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 29
Registered: ‎11-14-2008
My Device: Not Specified

Re: Momentics 10 crash when creating debug token; opensuse 13.1; other bugs

I couldn't find the file (program) you suggested to run, so I figured my installation was not correct. [I used every file finding trick I knew.]


When I read that page that said the SDK has to be installed as the user, I got the impression you could still have the IDE installed as root. However further down the page it was indicated that both the IDE and SDK should be in the user account. Obviously this is pretty odd. [WINE code is the only code I put in the user account.]


I suppose I could run the program as root, but that is a bad idea. So I found the uninstall command where the software was loaded on root and let it uninstall what it could. I still have some cleaing up to do. Then I installed the IDE and SDK in a user account and it created the token. Then it asked to download something else, which looks like it will run until the cows come home.


To summarize, the IDE/SDK seems to run on opensuse 13.1 64bit, though I still can't find the phone via USB. Unfortunately i had loaded up a lot of 32 bit libraries, so I don't know the minimal installation procedure on 64 bit opensuse. All I know is it could be made to load and it is running at the moment.


Obvously uploading code will be another story. I don't get 10.2.1 until mid February, so I guss I can just look at code examples in the meantime.


BTW, I was running wireshark on the usb port and it seems like Momentics never talks to it. But this is most likely a configuration error. When I port scan, it find ports that I doubt should be there, such as mediatomb on 50500. So clearly the system is mixing up ports on my computer with ports on the Z10.