Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Developer
Posts: 50
Registered: ‎11-15-2012
My Device: Q10
My Carrier: WIND
Accepted Solution

Native app stops at black screen

I have a native app that does some stuff, prints to stdout, and then exits.  When I run it through telnet, it works fine, but when I run it from the menu, it hangs at a black screen and logs/log gets created but is empty.

 

Any ideas?

Developer
Posts: 50
Registered: ‎11-15-2012
My Device: Q10
My Carrier: WIND

Re: Native app stops at black screen

I added some code to create files in /tmp as soon as the app starts.  If I run it through telnet, again, the files get created.  If I run from the menu, nothing gets created.

Developer
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Native app stops at black screen

Share you code with us.

What do you mean by telnet by the way?

Developer
Posts: 50
Registered: ‎11-15-2012
My Device: Q10
My Carrier: WIND

Re: Native app stops at black screen

I've found the issue (sort of) -- when running from the launcher, my app just consumes more and more RAM until it crashes.  It does not do this when run from the telnet console.  I will now embark on a mission to figure out what all the environment differences are between these two.

 

By telnet, I mean simply running telnet <simulator ip> from the host, and then using devuser as the username and password, whereupon I get a shell on the simulator.

Developer
Posts: 50
Registered: ‎11-15-2012
My Device: Q10
My Carrier: WIND

Re: Native app stops at black screen

I've found it.  For some reason my app was freaking out when LANG=C.  I have set LANG="" in blackberry-tablet.xml for now as a workaround.