Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 100
Registered: ‎10-01-2012
My Device: BB10 Dev Alpha
My Carrier: Roger

Re: No sound from bb::multimedia::MediaPlayer

Thanks for your posting. This information saved my time.
Retired
Posts: 127
Registered: ‎02-27-2012
My Device: Bold
My Carrier: Rogers

Re: No sound from bb::multimedia::MediaPlayer

Yes, the simulator only supports a limited number of audio formats and no video.

3GP, AAC, MIDI, MP3, Ogg Vorbis, and wav files, should be supported for audio. So I am not sure why your .mp3 doesn't work through MediaPlayer API.

Getting back to your previous comments, are you confirming that your .mp3 file, when renamed to .wav file, works on the simulator through your app? Please let us know if this is the case.

I am also getting the documentation team to update the public developer resources to reflect the simulator limitations, ASAP. Our apologies if your time wasted because of this.
Developer
Posts: 93
Registered: ‎10-29-2012
My Device: Z10
My Carrier: Various

Re: No sound from bb::multimedia::MediaPlayer

Thanks - no - I did not try to just rename the file from .mp3 to .wav That would not make sense. they are completely different file formats. I think that someone said that they converted their mp3 file to wav, then played it using the OpenAL libraries which in my case works as well.

 

For my test on the simulator - I found a web site that has wav and mp3 files on it. Clicking on wav opens the medial player and plays the audio. clicking on the mp3 file open the media player and then I get the rror I reported. 

 

If you need a screenshot I can post it as well.

 

Highlighted
Retired
Posts: 127
Registered: ‎02-27-2012
My Device: Bold
My Carrier: Rogers

Re: No sound from bb::multimedia::MediaPlayer

Yes, that makes sense. 

I will try to confirm again if MP3 is supported on the simulators. If you would like to make a feature request in the developer issue tracker, feel free to do so (for example: to support more codecs in the simulator).

https://www.blackberry.com/jira/secure/Dashboard.jspa


The more 3rd party developers we can have asking for certain features, the higher the chances that it would be pushed to the development teams.

Whenever you feel your original question/issue is solved, please click the appropriate "Accept As Solution"; it helps to track these posts better.

Developer
Posts: 93
Registered: ‎10-29-2012
My Device: Z10
My Carrier: Various

Re: No sound from bb::multimedia::MediaPlayer

Sounds good - thanks!