Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Contributor
Posts: 42
Registered: ‎02-17-2012
My Device: Newb Playbook Developer
My Carrier: -
Accepted Solution

OpenGL and Playbook simulator

Hi, I'm trying out the basic openGL based apps on playbook emulator and i have noticed that when the app windows is not fullscreen, the window does not appear as expected. This was true for sample openGL apps as well. I'd upload a screenshot but apparently i cant so i'll just describe it. Instead of displaying a mini version of the opengl app, it displays a blueish window with what looks like a hemisphere at the bottom.

 

So is there something i am doing wrong with the code or is it just a simulator limitation?

 
Contributor
Posts: 42
Registered: ‎02-17-2012
My Device: Newb Playbook Developer
My Carrier: -

Re: OpenGL and Playbook simulator

please guys i really need the answer to this one. Has anyone ever tried to run an opengl app on the simulator?

Developer
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: OpenGL and Playbook simulator

I am not seeing this behaviour on my Simulator. 

Contributor
Posts: 42
Registered: ‎02-17-2012
My Device: Newb Playbook Developer
My Carrier: -

Re: OpenGL and Playbook simulator

Hi bgmot. Thanks for the reply. May I ask what apps did you try on the simulator. Were they basic in nature like one of the sample apps or were they one of the more sophisticated programs? For instance, simply running the opengl template programme that comes with the ide that has a multi colored plane rotating would behave in the described manner for me.
Developer
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: OpenGL and Playbook simulator

I tried HelloWorld from samples.

Contributor
Posts: 42
Registered: ‎02-17-2012
My Device: Newb Playbook Developer
My Carrier: -

Re: OpenGL and Playbook simulator

Oh. But helloworld is not an opengl sample, is it?
Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: OpenGL and Playbook simulator

Yes, the HelloWorld from the NDK is OpenGL. If you continue to experience issues please provide a screenshot of the issue, the sample being used as well as version of NDK and simulator OS being used.

 

Regards,

Garett
@garettBeuk
--
Goodbye everybody!
Contributor
Posts: 42
Registered: ‎02-17-2012
My Device: Newb Playbook Developer
My Carrier: -

Re: OpenGL and Playbook simulator

It turns out that the HelloWorld app we're talking about here is same as the 'sample app' im talking about, so now you know the code. I've Uploaded a screenshot of the minimised app on flickr, here's the link :http://www.flickr.com/photos/77137187@N05/6917489495/

 

The NDK is version 1.00 beta3

The simulator is version 2.0.0.7109

 

Thank you for taking the time to help me out Smiley Happy

 

P.S.: I tried the same app on emulators on two pcs other than my own just to verify that it didnt have anything to do with my hardware but the result was the same.

Contributor
Posts: 42
Registered: ‎02-17-2012
My Device: Newb Playbook Developer
My Carrier: -

Re: OpenGL and Playbook simulator

[ Edited ]

I should also add that this app doesnt play well with other apps that are open. for instance, when i minimise it and tap on the browser icon, then as soon as the browser becomes fullscreen, the opengl rendering of the said app is displayed as if it was the active app

I managed to stop this behavior by calling the render function only when the app was in fullscreen, but the original problem remained.

So should the app have been behaving that way?

Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: OpenGL and Playbook simulator

I just reproduced the issue and it does appear to be a bug. Please post to Issue Tracker and I will escalate:

Issue Tracker

Garett
@garettBeuk
--
Goodbye everybody!