Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 828
Registered: ‎10-16-2012
My Device: Red Z10
My Carrier: Rogers
Accepted Solution

Package version issue

[ Edited ]

Tried submitting an update to an app and got this

 

  • BAR Package-Version for a lower Min. OS cannot be greater than the BAR Package-Version of a higher Min. OS. Or for same Min. OS, the package versions must be same.

 

does this mean that since I released a 10.2 version of the app that I can no longer update the versions lower than 10.2?  I can't understand anything else that could mean, I haven't changed anything api level related

 

Or does it mean that in this curcumstance I need to keep the old version number(from the .bar) of my previous release for any future updates?

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Package version issue

(Guessing) The way I read it, it means that any time you are going to upload multiple bars for different "Min OS" values, you should generate and sign them in ascending order by Min OS value.

That is, if you'll upload two bars, one set for 10.1 and the other for 10.2, you would need the version for the 10.2 one (say, 2.7.123.101) to be higher than the one for 10.1 (e.g. 2.7.122.100 and not 2.7.124.100). That would also restrict the order in which you sign them, since the signing server doesn't allow the version ever to go down.

In short, it seems you shouldn't generate a 10.2 before a 10.1 which you'll also be uploading, and if you do a 10.2 and later want to do a 10.1, make sure the version is higher.

Really just guessing though, based on the text you showed.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
Posts: 828
Registered: ‎10-16-2012
My Device: Red Z10
My Carrier: Rogers

Re: Package version issue

[ Edited ]

Well I got past it, Still no idea why the error occured

 

To get past it I submitted the 10.0 Z bar in its own release and then submitted the 10.1 Q bar in its own release.  I've been able to submit them together without issue before.

 

Perhaps it is because i selected the release targeted to 10.1 first, I'll test that out next time i update