Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Regular Contributor
Posts: 76
Registered: ‎06-14-2013
My Device: Z10
My Carrier: PosteMobile

Re: Permission denied on path /dev/nfc/ese

[ Edited ]

Unfortunately I'm not seeing that exchange. I don't know how to verify it. I know that i can use the SE or the ESE but not both. I read that here:

http://supportforums.blackberry.com/t5/Java-Development/NFC-Primer-for-Developers/ta-p/1334857

But i don't know if i send the APDU through the NFC, it result in using the ESE to comunicate to the SIM card. I'm using the API to send the APDU, i'm not coding manully the procedures, so i think the operations should be done in the right way but something goes wrong. Actually this part is coded by the NfcTool team who has done the APDU test, i modified only the initial part to send a manually coded APDU instead of the manually inserted from the gui. Even if i use the "original version" it give me the same error "NFC_RESULT_SE_REQUEST_REJECTED"


The only things i know are:

1- The SIM does work because from the SIM Toolkit a can browse the carrier services and when the phone is powered on it ask me if i want to receive the configuration for MMS and other stuff from the carrier.

2- The APDU should work because the guy who has gived me the SIM told me that the APDU is valid so if it reach the SIM, it have to send me back a response. Even if it is incorrect i should get the error "NFC_RESULT_SE_INVALID_APDU" but if I send no sense values i get ever the error "NFC_RESULT_SE_REQUEST_REJECTED" so the problem is in the comunication not in the APDU

Therefore i think the problem could be the Z10 OS version which is bugged or could be the framework version used to compile the NfcTool sample that actually is the most updated.  

Regular Contributor
Posts: 50
Registered: ‎04-27-2012
My Device: BlackBerry Q10
My Carrier: 447713279379

Re: Permission denied on path /dev/nfc/ese

First thing is your SIM has to have SE; but even with that you need permission to use such from the Network Provider. You need to check the Martin Wooley details (the author of the NFCTools). He was really helpful while I worked on this project, and I am sure you will find enough help with him too. His details should be on the GitHub. 

 

Regards

NFC on my mind!!
Retired
Posts: 571
Registered: ‎06-25-2010
My Device: Z10
My Carrier: Vodafone

Re: Permission denied on path /dev/nfc/ese

Yes, as Rob says, you can and should ignore this message in the logs. I know it's disconcerting to see it. It relates to the embedded secure element which is not available for use at present.

--------------------------------------------------------------------------------------------
Feel free to press the like button on the right side if you liked my attempts to help :-)
And please mark posts as solved if you think I found the solution or set you on its path. Thanks!
Follow me on Twitter: @mdwrim