Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Trusted Contributor
Posts: 232
Registered: ‎11-19-2010
My Device: Z10, Playbook

Playbook Simulator 2.1 won't start

I've seen other post with similar problems but the posted solutions aren't helping me.

I have VM player 5.0.0 build-812388 and it runs the blackberry 10 simulator fine. I use the 10-NDK with it and all is good.

I try to run the playbook simulator (2.1.0) and it starts with just a black screen. If i click in the simulator and move the mouse around, I can see the cursor for only the top left quater of the simulator screen. The cursor disappears if i move past about half way to the right or down. No icons or any other simualtor stuff is visible.

If I go under edit virtual machine settings for the simulator, under the options tab, the guest operating system is set to other and version other. If I change this to Windows 7-64 and try to start the simulator, the VM player window just briefly flashes black then comes back to where you select the simulator you want to run.

I am able to target my NDK-2.1 builds to my actual PB device, but I will need the simualtor too.

Any suggestions?

New Contributor
Posts: 9
Registered: ‎10-10-2012
My Device: Playbook/Bold 9780
My Carrier: Bell

Re: Playbook Simulator 2.1 won't start

I have the same problem! Had any update?
Posts: 195
Registered: ‎05-09-2012
My Device: Playbook, Z10 LE

Re: Playbook Simulator 2.1 won't start

[ Edited ]

You can try VM Ware Player 4. I cannot remember if I have tried the OS 2.1 simulator in VM Ware Player 5 recently but BB10 works now definitely.


Also be sure to enable (and that you have) virtualization support for your CPU, it makes for all the difference! Without VT-x enabled earlier versions of BB10 would either take forever to load or even fail to boot. Initially I thought that VT-x was enabled but later I found out that they were disabled in BIOS. After I have enabled virtualization everything was fine.



Also (WARNING) software like "Synergy" messes with the simulator's cursor. So if you use something like that, you need to disable it prior to using the simulator.