Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 180
Registered: ‎12-09-2011
My Device: 9360, BB10
My Carrier: Aircel
Accepted Solution

Problem when updating APIs for 10.2.0.1155

Hi All,

 

I am getting error "API Level Modification" when i am trying to update the API level.

For more information please see the attached screenshot.

 

Please suggest any solution for this its urgent.

 

Thanks in Advance.Error Screen

Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Problem when updating APIs for 10.2.0.1155

Similar thread with answers here...

 

http://supportforums.blackberry.com/t5/Native-Development/New-10-2-Gold-install-API-error/td-p/25468...


If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
Developer
Posts: 180
Registered: ‎12-09-2011
My Device: 9360, BB10
My Carrier: Aircel

Re: Problem when updating APIs for 10.2.0.1155

Hi BBSJdev, I already read this thred suggested by you i did all the possible steps and as well as change the permission of .lock file then also i am getting the same problem again and again. 

 

I already report it to Report Blackberry Native SDK Bug.

 

Please suggest any solution for this.

 

Thanks in Advance.

Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Problem when updating APIs for 10.2.0.1155

Have you tried completely deleting the whole of the bbndk folder and reinstalling?

Sadly this seems to be a solution to many Momentics problems.
Also moving the workspace folder to a new one sometimes works miracles.

If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Problem when updating APIs for 10.2.0.1155

Now that I can see your pic, this is the exact same problem I had a few weeks back and others, with the only solution being to delete everything and start again...

 

http://supportforums.blackberry.com/t5/Native-Development/10-2-gold-sdk-10-2-API-update-problem/td-p...


If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Problem when updating APIs for 10.2.0.1155

If that doesn't work you might like to PM calcratis and see if he ever did get it fixed.


If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
Developer
Posts: 163
Registered: ‎12-06-2012
My Device: Z10, Q10
My Carrier: BlackBerry

Re: Problem when updating APIs for 10.2.0.1155

[ Edited ]

Hi. I still could not get it fixed. The only other way around is to update the native sdk 10.0.9. Install that SDK and then update the SDK to what you need. That works perfectly. I have faced this issue in several other machines also.

Regular Visitor
Posts: 1
Registered: ‎09-11-2013
My Device: developer

Re: Problem when updating APIs for 10.2.0.1155

I've had the same problem while trying to install 10.0 API (10.2 & 10.1 installed ok) and was able to solve it. I guess that something went wrong while the zip files were downloading, and that one or more were corrupt. However, I couldn't find the files so I could delete them.Eventually, I figured out what to delete.

I went to the folder "C:\bbndk\p2\org.eclipse.equinox.p2.core\cache"  and made copies of the artifacts.xml file and .blobstore folder in case someting went horribly wrong. Then, I changed the content of the artifacts tag in artifacts.xml from 

<artifacts size='4'>
    <artifact classifier='packageWin32' id='bbndk.win32.tools.10.0.10.536' version='1.0.0'>
      <properties size='2'>
        <property name='artifact.uuid' value='4044df69fb1a00131b6ee68fc89624a3'/>
        <property name='download.size' value='94452325'/>
      </properties>
    </artifact>
    <artifact classifier='packageWin32' id='bbndk.win32.samples.10.0.10.822' version='1.0.0'>
      <properties size='2'>
        <property name='artifact.uuid' value='40d27a68fb1a00131b6ee68fc89624a3'/>
        <property name='download.size' value='102550'/>
      </properties>
    </artifact>
    <artifact classifier='packageWin32' id='bbndk.win32.licenses.10.0.10.822' version='1.0.0'>
      <properties size='2'>
        <property name='artifact.uuid' value='60207b68fb1a00131b6ee68fc89624a3'/>
        <property name='download.size' value='60182'/>
      </properties>
    </artifact>
    <artifact classifier='packageWin32' id='bbndk.win32.documents.10.0.10.822' version='1.0.0'>
      <properties size='2'>
        <property name='artifact.uuid' value='00367a68fb1a00131b6ee68fc89624a3'/>
        <property name='download.size' value='34012066'/>
      </properties>
    </artifact>
  </artifacts>

 to 

<artifacts size='0'/>

 and I deleted the appropriate files in the .blobstore folder (i.e. all files). After that I was able to install the 10.0 API without any problems.

I hope this will help you solve your problem Smiley Happy

 

Developer
Posts: 151
Registered: ‎09-28-2012
My Device: Blackberry Developer
My Carrier: Aircel

Re: Problem when updating APIs for 10.2.0.1155

Hi All, I am also facing the same problem. Try to reinstall everything then also no solution. Smiley Sad

 

Please suggest any other way.


----------------------------------------------------------
Feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Problem when updating APIs for 10.2.0.1155

Have you tried milicadwbh's solution?

If not try it and let us know if it worked?

If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.