Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 554
Registered: ‎10-31-2009
My Device: Torch 9800, Bold 9700
My Carrier: Movistar, Telenor

Problems with debug tokens and..

[ Edited ]

I am exploring  Cascades and native. Setup:


Windows 7 English version. Regional setting English US


Simulator  BB10_1_X.1483      IP:


Autodiscover comes up with the following

USB Device        ?????       Where did this come from? I have only one running!


New debug tokens generated. They can be uploaded by batch file to the simulator but import says:

"unable to parse expiry date from debug token"


Only message is "deploy failed"


Have restarted computer just in case but no.


This worked yesterday  and I am not aware of any changes except I started on the next sample "Native"


Launching gets stuck on 78% "Configuring GDB"


Manually importing debug tokens, both old and new ones gets the "unable to parse.." message



If everything seems to be under control, you're just not driving fast enough
-Mario Andretti-
BlackBerry Development Advisor
Posts: 15,889
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Problems with debug tokens and..

Debug tokens are not required when using the BlackBerry 10 Simulator, only on a real device.


Are you getting errors deploying to your device or just the simulator?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 50
Registered: ‎05-01-2013
My Device: Dev Alpha B - Dev Alpha C
My Carrier: Ooredoo

Re: Problems with debug tokens and..

I got issus while trying to deploy on a simulator ! :s

1. If any post helps you please thumb's up below .
2. Please resolve your thread by marking the post Solution which solved it for you !!
Posts: 554
Registered: ‎10-31-2009
My Device: Torch 9800, Bold 9700
My Carrier: Movistar, Telenor

Re: Problems with debug tokens and..

Sorry I forgot this thread. It works now. I am not sure what caused the problem. I am deploying to the simulator. Since the error message was about interpreting a date and it occured when I tried to import the tokens I suspect a a date format problem. I was using 2 computers due to problems with the graphics card on one of them. It might be that the token where generated on a computer with Swedish settings (and date settings) and used on a computer with US settings but I am not sure. After I got the US computer uppgraded with a new graphics card so I can run the simulator on it and also created the tokens on it the problem has disappeared.


Using debug tokens was a routine from when I used  Ripple


Date formats are tricky things. A couple of years ago I was developing software  with international distribution that had an interface with Excel.

All dates where stored as "long" in the Microsoft format. If I remember  correctly  1 was January 1 1900



If everything seems to be under control, you're just not driving fast enough
-Mario Andretti-