Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Developer
Posts: 656
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

QML Editor Issue - "Missing Root Component"

I have a QML file that is working but I can't edit it with drag and drop and there is a red X on first line that says "Missing Root Component" .  I have a Navigation Pane already.  Anyone else seen this?  Thx.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Developer
Posts: 121
Registered: ‎11-19-2008
My Device: Not Specified

Re: QML Editor Issue - "Missing Root Component"

I am getting the same error message. The QML I have contains a SystemDialog which I would like to re-use from different places in my code.

 

Interestingly, when I change the top-level element to say Sheet the error message goes away...

 

 

New Developer
Posts: 168
Registered: ‎04-12-2010
My Device: Storm
My Carrier: Verizon

Re: QML Editor Issue - "Missing Root Component"

Reboot ... that took care of it for me

Developer
Posts: 145
Registered: ‎12-23-2012
My Device: BB10 Dev Alpha
My Carrier: wifi

Re: QML Editor Issue - "Missing Root Component"

I faced the same problem once when I create QML files in Src folder , instead of Asset folder. Once I moved the files to asset folder it started working fine.

 

But there might be other causes as well for the issue