Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Developer
Posts: 6
Registered: ‎12-03-2012
My Device: NAN
My Carrier: NAN
Accepted Solution

Qt Creator | Simulator

Hello everybody

 

I tried to configure Qt Creator for BB10. And after long time I succeed! But now I am facing an other problem..

I don't have a device, so I want to deploy on the Simulator but It doesn't.. It gives me this error :

 

result::failure 821 Application-Requires-System: unrecognized system name 'BlackBerry 10'

Error while building/deploying project btest (kit: BlackBerry 10 (target_10_0_9_1673) - Simulator)

Lors de l'exécution de l'étape "Deploy packages"

 

I am using using QtCreator 2.6.81

BBndk Gold

for the simulator I use Wmplayer with BlackBerry10Simulator-Installer-BB10_0_09-386-Linux-201209241939

And all of this run under Ubuntu 12.10

 

Thank you for your help!

New Contributor
Posts: 3
Registered: ‎05-16-2012
My Device: Playbook
My Carrier: T-Mobile

Re: Qt Creator | Simulator

Hi,

I guess your QtCreator already provides an automatic setup for BlackBerr 10 ( You do have a BlackBerry Setting Page to specify the NDK path right?)

if not, did you specify the mkspec "blackberry-x86-qcc" ?

Highlighted
New Developer
Posts: 6
Registered: ‎12-03-2012
My Device: NAN
My Carrier: NAN

Re: Qt Creator | Simulator

It's fine I have fixed the issue!

 

BBNDK's and Simulator's versions did not agree..

So I have download the latest for each ones and now it rocks!

 

Thankl you anyway!!