Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 28
Registered: ‎11-07-2013
My Device: 9790
My Carrier: VietNam

Run on BB10.2 and 10.3

can applicaton run on BlackBerry 10.2 and BlackBerry 10.3

 

how? help me?

Developer
Posts: 1,044
Registered: ‎07-21-2012
My Device: BlackBerry Bold 9900/9780/9810
My Carrier: Singtel

Re: Run on BB10.2 and 10.3

Hello Aric,

Sorry, could you be a little more specific?
Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Run on BB10.2 and 10.3

yes, as long as you do not use any features that were added in 10.3

if the application runs on 10.2 it will also run on 10.3
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 28
Registered: ‎11-07-2013
My Device: 9790
My Carrier: VietNam

Re: Run on BB10.2 and 10.3

[ Edited ]

 

 

i have an application with function

- lock call (BlackBerry 10.3 )

- led call ( BlackBerry 10.2 )

- ....

 

 

when run on device 10.3 with full function

device 10.3 : not has lock call

 

 

sr. i'm bad EL. Smiley Very Happy

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Run on BB10.2 and 10.3

no, you need to compile with 10.2 to run an application on 10.2, and if your c++ code contains features from 10.3 it would not compile.

if these features are in qml you could to it with dynamic loading.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 147
Registered: ‎05-31-2013
My Device: BlackBerry Z10 Limited Edition
My Carrier: Bonbon

Re: Run on BB10.2 and 10.3

Also in QML you must use

Import bb.cascades 1.2 because it works the same on both 10.2 and 10.3.

I wish BlackBerry would release a 10.2.2 OS update with Cascades 1.3 backwards compatibility.