Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

New Developer
Posts: 18
Registered: ‎11-13-2012
My Device: Z10, q10
My Carrier: freelancer

[SOLVED]no QtGlobal but -I defined

[ Edited ]


Could somenone help me with this one ? 

ik have cocos2dx application ( 2x) , and i would like to add little functionality to library - i need to 


i have adde such a function to CCApplication.cpp


void CCApplication:Smiley SurprisedpenURL(const char* pszUrl)
InvokeManager invokeManager;
InvokeRequest request;
// Who do we want to send the invoke request to?
// What do we want the target application to do with it?
// What are we sending?

// Where is the data?



and include directive 

#include <bb/system/InvokeManager>


thern I get error about missing QtGlobal 

so I've added additional include directory what You can see in output

Include Directive



but i Still gets this Error :/








qcc -o "platform\\blackberry\\CCApplication.o" "..\\..\\platform\\blackberry\\CCApplication.cpp" -V4.6.3,gcc_ntoarmv7le_cpp -w1 -shared -IC:/bbndk/target_10_2_0_1155/qnx6/usr/include/freetype2 -IC:/bbndk/target_10_2_0_1155/qnx6/../target-override/usr/include -I../../../ -I../../../cocos2dx -I../../../cocos2dx/include -I../../../cocos2dx/platform -I../../../cocos2dx/platform/blackberry -I../../../cocos2dx/kazmath/include -I../../../cocos2dx/platform/third_party/blackberry/include/libtiff -I../../../cocos2dx/platform/third_party/blackberry/include/libwebp -IC:/bbndk/target_10_2_0_1155/qnx6/usr/include/qt4 -D_FORTIFY_SOURCE=2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -c -O2
In file included from C:/bbndk/target_10_2_0_1155/qnx6/usr/include/bb/system/Global:7:0,
from C:/bbndk/target_10_2_0_1155/qnx6/usr/include/bb/system/InvokeManager.hpp:10,
from C:/bbndk/target_10_2_0_1155/qnx6/usr/include/bb/system/InvokeManager:7,
from ..\..\platform\blackberry\CCApplication.cpp:9:
C:/bbndk/target_10_2_0_1155/qnx6/usr/include/bb/system/Global.hpp:10:20: fatal error: QtGlobal: No such file or directory

New Developer
Posts: 18
Registered: ‎11-13-2012
My Device: Z10, q10
My Carrier: freelancer

Re: no QtGlobal but -I defined

OK I was ab;e to solve it.


First of all i had to add two directorites to include PATH :




in cocos2dx Project.

rthe i had to add them in my project.


it was also required to link to bbsystem and QTcore.

I had to also add qt directory  to -L 



and after that Iwas able to compile project. 

But  on the device it crashed with a message:

blackberry ldd:FATAL: Could not load library libQtCore.so.4

so I changed bar description

<env var="LD_LIBRARY_PATH" value="app/native/lib:/usr/lib/qt4/lib"/>

And now it's runing and can open Pages from app Smiley Happy 





Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: no QtGlobal but -I defined

That's great but use the 'Accept as solved' button rather than editing the title.

If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.