Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 46
Registered: ‎02-22-2012
My Device: Developer
My Carrier: Various

SceneCover problems on Dev Alpha devices...

We are having problems getting SceneCover to work on real Dev Alpha device.


SDK = Beta 4

Dev Alpha device says OS Version


The app is an Opengl Cascades app, thus a foreign window involved.

Tried + tested our apps on simulator. They display the SceneCover as expected. Its a simple static image.


Moved to testing apps on real device.

The apps generate a Segmentation Fault in thread 2.

As far as we can see Thread 1 is the main thread + we dont create any app specific threads, so this thread is presumably something to do with some of the BB10 system we are using. (Just to clarify, opengl is NOT running in a different thread so its not the opengl thread crashing)


Stack trace generated is minimal, being only 3 calls deep, non of which have any symbolic info. That + attempts to look at disassembly output seem to suggest the thread has leap to invalid code.


Weve tried lots of things to try to locate the fault e.g.

i) SceneCover in CascadesCookbook (c++) example works on simulator + device.

ii) helloforeignwindow example app works on device (cut+paste the cookbook SceneCover code + image)

These are from the latest Cascades Samples 

iii) weve replaced the cookbook image with our cover image + it gets displayed correctly.

iv) weve replaced our app code with the cookbook code + image + tried it. It works on simulator + crashes on device.


The above hints that the image is fine, foreign windows dont cause problems + the general SceneCover mechanism should be working.


However, non of the cascades sample apps appear to use OpenGL. So taking the GoodCitizenCascades app + adding the CookBook Scenecover code results in:

i) working as expected on simulator

ii) SceneCover not being displayed at all on the Dev Alpha device. App does not crash, however if you attempt to maximize the app + allow it to continue it seems rather broken, menu + button bar not respond, ui display really broken...


So it appears that OpenGL + SceneCovers dont like each other on real devices. 

Or have we missed some magic switch/permission etc required for this to work ?