Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
Developer
Posts: 136
Registered: ‎02-01-2009
My Device: Not Specified
Accepted Solution

Simplest TextArea not working

I'm trying to set the text of a TextArea from C++, but it the page is going plain dark ( splash) with no error messages in the logs.

 

I have tried it in both simulator and Dev Alpha device and same thing happend.

 

QmlDocument *qml = QmlDocument::create("logger.qml");
	AbstractPane *root = qml->createRootNode<AbstractPane>();
	txtArea = root->findChild<QObject*>("txtName");
//    	QString temp="";//txtArea->text();
//    	temp.append("Text:");
 	txtArea->setProperty("text", "Text:");

	qDebug() << "JSON data loaded OK!";
	Application::setScene(root);

}

 

If i comment the 'setProperty' line, the empty text area comes just fine.

 

As you would notice I tried the setText too, but that also failed.

 

 

Developer
Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: Simplest TextArea not working

[ Edited ]

Use TextArea* instead of QObject* in findChild<TextArea*>("textAreaObjectName");

Retired
Posts: 499
Registered: ‎05-07-2012
My Device: developer
My Carrier: developer

Re: Simplest TextArea not working

I changed a sample I have that uses a TextArea to use a QString instead, commenting out all TextArea methods and just doing your setProperty line.  This worked fine for me.   I also tried just changing the findChild to findChild<QObject*>.  When my variable is a TextArea*, this gives a syntax error unless I do:

 dynamic_cast<TextArea*>(m_mainPage->findChild<QObject*>("textAreaObjectName"));

 

So if the previous suggestion is not enough, change your txtArea variable to a TextArea* and check that the findChild actually returns something.

 

Stuart

 

Retired
Posts: 499
Registered: ‎05-07-2012
My Device: developer
My Carrier: developer

Re: Simplest TextArea not working

Did you make any progress on this?

(If so please mark a post as solution -- even if it's yours (please briefly indicate what your solution was in this case)

 

Stuart