Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Developer
Posts: 58
Registered: ‎09-25-2012
My Device: Dev Alpha, Z10
My Carrier: MTS

Sometimes own splash screen is not shown

Hi guys,

 

I have a problem with my own splash screen's visibility.
Usually it is works, but sometimes my own image replaced by default "Blackberry 10" image.

 

code of splash screen section in the bar-descriptor.xml:

 

    <asset path="assets/images/splashscreen.png">splashscreen.png</asset>
    <asset path="assets/images/q10/splashscreen.png">splashscreenQ10.png</asset>
    <splashScreens>
        <image>splashscreen.png</image>
        <image>splashscreenQ10.png</image>
        <image>
           <text xml:lang="en">splashscreen.png</text>
        </image>
        <image>
           <text xml:lang="en">splashscreenQ10.png</text>
        </image>
    </splashScreens>

images info:

splashscreen.png - dimensions 768x1280, size 368 KB

splashscreenQ10.png - dimensions 720x720, size 323 KB

 

 this issue can be observed on the both Z10 (OS BB 10.1.0.4633, Software Release 10.1.0.4181) and Q10 (OS BB 10.1.0.1429, Software Release no info available) devices.

 

 

I don't have fixed steps, but i have tried around, and the issue is not too difficult to reproduce:

1. launch app. See if the splash screen is removed. If not, delete it, and do a fresh install by command line.
2. launch app. See if the splash screen is removed.

 

keep doing it, eventually, i see the splash screen is removed. Once it happens, the splash screen will be missing each time launching app. But rebooting device will recover it.

 

Anybody know what is it and how it can be fixed?

 

Thanks!

Retired
Posts: 749
Registered: ‎12-16-2008
My Device: BlackBerry Z30
My Carrier: Bell

Re: Sometimes own splash screen is not shown

Could be some sort of cacheing  issue. Are you able to reproduce it on 10.2? Has an end user ever actually seen it when the app is installed through BlackBerry World?

Paul Bernhardt
Application Development Consultant
BlackBerry
@PBernhardt

Did this answer your question? Please accept this post as the solution.
Found a bug? Report it to the Developer Issue Tracker