Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 12
Registered: ‎01-25-2013
My Device: Blackberry Playbook
My Carrier: Vodafone

Still having problems signing.

Spent another frustrating day yesterday trying to figure out why the signer won't sign my game's bar package. I think it's because of the original project name. So I decided to launch an example project that has just a single word as its project name. Tried to sign that as a test and this time I got manifest errors!!


I did this test as I was thinking of setting up a fresh project with a single word as the project name and then copying all the files from the original project over to it. But if a simple example won't sign, what's the guarantee that after copying all the files and assets over to the new project that this one will sign?


Seriously, Blackberry - you really need to sort this out. The whole signing process is ridiculous.  I'm on the brink of giving up with the platform, which is a shame as I like it. I've tried everything ... sometimes twice or three times. The only other option is to ditch Visual Studio and Marmalade and start again with Momentics and the Gameplay engine. But if that's the case then I'll have to leave it for now and use my current code base as a basis for Windows Phone and Android versions of the game. At least Microsoft do the signing for you.


The only other thing I might have overlooked is the importance of the author.p12 file. I can't remember how I created it previously as the one I have wasn't created with my current keys. I need to make sure that everything matches before finally giving up the ghost.

Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Still having problems signing.

There are thousands of apps in BlackBerry World, all of which had to be signed, you need to sign apps on Android as well.

There is nothing wrong with the signing process therefore it's something on your end.

   (This sounds blunter than I meant it to be sorry)


If you've followed the steps for signing, have the passwords correct it should be straightforward.


Have you posted this on the marmalade forums as well or searched their forums for similar problems as if you believe you are doing it correctly, logically it's the marmalade/VC side that's messing you up.


As I recommended in the other thread try posting the exact steps you are using to sign your app with any command line options you are using and we'll see if it's anything obvious.









If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
Posts: 12
Registered: ‎01-25-2013
My Device: Blackberry Playbook
My Carrier: Vodafone

Re: Still having problems signing.

I'm having a break from it at the moment, otherwise I'd need a new PC and a new window.


I think the plan should be for me to:


1. Wipe all the keys I have.

2. Unregister for signing.

3. Reregister and get new signing keys (already done this a couple of times).

4. Go back to the project and set up the duplicate project as planned (I am convinced it's a Visual Studio project setup issue).

5. Try again.


What would have been helpful is if there was a project setup tool similar to the one in Momentics.


I will try the Marmalade forum but I'm not sure how much help they'd be with the signing process.