Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
Contributor
Posts: 15
Registered: ‎10-25-2012
My Device: Dev Alpha B
My Carrier: Megafon

Using PPS service in my application

Hi,

My product consists of 2 modules: 1) service 2) UI application. I want to use PPS for communication between 'service' and 'ui application'. Can I do it on Blackberry Dev Alpha? I've tried to create PPS channel inside /pps/services/ but I have an error 'permission denied'. I tried to open it inside /tmp/ but it seems it is just a single file, not a PPS channel (i.e. the file "/tmp/service?wait,delta" was created).

Does anyone know, is there any example of how 3-rd party developers can use PPS for inter-process communication?

 

Thanks

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Using PPS service in my application

There's no documented support for doing this, and for now it seems use of PPS by third-party apps is a risky thing to consider building into apps.

If you want to try experimenting, I suspect you'd want to stick to the ./pps symlink which you'll find in your app's sandbox folder when it runs.  That links to a subfolder of /pps where it appears app's may get their own area, in future.

In my Battery Guru app running on the device now, that looks like this:

lrwxrwxrwx   1 root      nto              76 Jan 31 11:54 pps -> /pps/accounts/1000/appserv/ca.engenuity.PowerMon.testDev_ty_PowerMon4990f05_

The destination folder does not currently exist, and our apps have no write access to the parent, so either there's intended to be an API layer which would create that folder at the appropriate time, or the support simply isn't in place yet.

 

I'll note that this "appserv" folder is either brand new with this release, or was added in Gold 2 (the previous one)... I didn't check there lately so I'm not sure when. The important point is that this is an area of rapid change and you'd be quite unwise to actually try delivering apps that make use of it for now.

 

By all means, however, experiment away and please let us know what you find. :-)


Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!