Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Using a new version of a library

I am using a webservice library (kdsoap). An issue on it was fixed and i rebuilt the library, copied it over to my project and tried to run it again.

However, the error remains. I check the source code and it is fixed, and a unittest proves that, so it seems that the newer version of the library is not used. I tried cleaning the project, but to no avail.

 

So i decided to create a new project, copied the stuff over and tried to run that.

Now i get

ldd:FATAL: Could not load library libkdsoap.so.1

 

Adding the librady as libkdsoap.so.1 does not help as it seems.

I tried creating a third project and using LIBS+=-lkdsoap2 while renaming the library to libkdsoap2.so, but i get the same FATAL message as above.

 

How can i get rid of the old version (assuming there is one) and put the new version in there? Uninstalling the other app did not help.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter