Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 101
Registered: ‎08-04-2008
My Device: Passport / Q10
My Carrier: T-Mobile

XPCOM error 0x80004005 in 10.2 SDK Momentics IDE on fresh install of Ubuntu 12.04 LTS 64bit

I setup a new VM with Ubuntu 12.04LTS for my development environment, it's nice to have a completely clean system to work with when moving to a new SDK version.  Followed the normal installation instructions and added the needed libraries to my 64bit system the same as I've had to do with previous 10.X SDKs and that all worked as expected.


However when I first launch Momentics the welcome tab is blank and has only the "XPCOM error 0x80004005" error at the top of it.  It looks like an issue with xulrunner of which I installed a 64bit compatible version of and the issue still remains.  I tried starting Momentics with a switch of "-Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner" (and other varients of that path) and couldn't effect any change in behavior.


Known issue or is there something else I missed in the setup / configuration for 10.2?

Posts: 38
Registered: ‎01-13-2013
My Device: BlackBerry Z10, Q10
My Carrier: Claro (Brazil)

Re: XPCOM error 0x80004005 in 10.2 SDK Momentics IDE on fresh install of Ubuntu 12.04 LTS 64bit

I saw the same message even after installing xullrunner 10.0.2 dowloaded from here. and extracting it at /opt, on Ubuntu Linux 13.04.


Then I realized that some i386 libraries on which xulrunner depended were missing. I is easy to list them by running these commands (as root, in my case):


    # cd /opt/xulrunner/
    # LD_LIBRARY_PATH=/opt/xulrunner ldd *.so|fgrep 'not found' |sort -u
    libasound.so.2 => not found
    libdbus-glib-1.so.2 => not found

Then I found the packages providing the missingg libraries with


    # apt-cache search libasound
    # apt-cache search libdbus-glib

and installed them with


   # apt-get install libasound2:i386 libdbus-glib-1-2:i386


And ta-daaaaa!