Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 44
Registered: ‎06-16-2012
My Device: BB10 Dev Alpha

Yet another "author.p12" problem with Momentics?



I'm trying to create a debug token to deploy an app to a Dev Alpha C but Momentics is prompting me for my author.p12 password. I enter this and it then prompts me yet again.


I've previously signed & deployed to a Dev Alpha and a Playbook via Momentics and the command line respectively (so I know it should work).


To fix my current problem I've tried:


i) using backups of my author.p12, barsigner.csk and barsigner.db files, but that doesn't work.

ii) deleting author.p12 and recreating the 'Developer Certificate' in Momentics. The strange thing is it then immediately prompts me to enter the password and it does not accept the new password!?


Any ideas please? This convoluted process is a massive time waster - I hope BB can sort something better out!

Blog: http://partialpivot.blogspot.co.uk/
Posts: 17,025
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Yet another "author.p12" problem with Momentics?

i had the same issue and was quite dumbfounded by it, but i was able to resolve it by restoring the key from the backup.
also happened when i wanted to create a debug token on my DevAlphaC
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Posts: 44
Registered: ‎06-16-2012
My Device: BB10 Dev Alpha

Re: Yet another "author.p12" problem with Momentics?

Thanks - that didn't work for me this time. I could do with an error message to pinpoint the problem - Momentics just keeps reprompting.


I'm going to try recreating the author.p12 file from the command line. (I used the BB PB21 NDK binaries to do this for the Playbook as it seemed to be an issue - maybe BB10 NDK binaries are different.)


Another evening wasted trying to hack something that should just work! [Sigh]

Blog: http://partialpivot.blogspot.co.uk/
Posts: 44
Registered: ‎06-16-2012
My Device: BB10 Dev Alpha

Re: Yet another "author.p12" problem with Momentics?

[ Edited ]

This is frustrating. I'm sure there's a problem with Momentics, otherwise how can I do the following via the command line?...


So I recreated my author.p12 file (passwords are identical for CSK and storepass and have not changed since registration):


blackberry-keytool -genkeypair -keystore (output file name) -storepass (another password) -dname "cn=(your company name)" -alias author

 and created a debug token for my device:


blackberry-debugtokenrequest -cskpass (your password) -keystore (your keystore file)
 -storepass (another password) -deviceId 0x(your device PIN) (output file name)

I then switched to development mode on the device and deployed the debug token:


blackberry-deploy -installDebugToken (your debug token) -device (IP address) -password (device password)

and this deployed successfully. If I had simply forgot my CSK or author.p12 password why does this work?



I've tried reinstalling Momentics, deleting and restoring the siging keys (via the Momentics interface). So the interface behaves as follows:


Open Momentics, click 'Windows'-'Preferences' menu options then 'Blackberry'-'Signing'. I'm prompted for my author.p12 password which I enter:




It then immediately responds with the same Window. I repeat process, but it keeps coming back. Eventually I give up and press cancel and the dialog window looks like this (username blanked out, but the 'Author:' field is as it appears in Momentics)




Any ideas what's wrong please? I got a less than helpful tweet back from @blackberrydev and despite not liking Momentics (more of a Qt-Creator fan), I've just about got used to it.

Blog: http://partialpivot.blogspot.co.uk/
Posts: 749
Registered: ‎12-16-2008
My Device: BlackBerry Z30
My Carrier: Bell

Re: Yet another "author.p12" problem with Momentics?

It sounds like it may be a bug of some sort. Can you reproduce the problem and then submit it (from the NDK, Help->Report BlackBerry Native SDK Bug)


Does it work with the 10.0 SDK?

Paul Bernhardt
Application Development Consultant

Did this answer your question? Please accept this post as the solution.
Found a bug? Report it to the Developer Issue Tracker